summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01af6de87262..31ef31d9b345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-pykcs11
pkgdesc = PKCS#11 wrapper for Python.
- pkgver = 1.5.5
+ pkgver = 1.5.11
pkgrel = 1
- url = https://github.com/LudovicRousseau/PyKCS11
- arch = any
+ url = https://github.com/LudovicRousseau/pykcs11
+ arch = x86_64
license = GPL
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = swig
depends = python
- depends = swig
- source = https://github.com/LudovicRousseau/PyKCS11/archive/1.5.5.tar.gz
- md5sums = 7ad2bc49e4a122b7118494e04251b999
+ source = python-pykcs11-1.5.11.tar.gz::https://files.pythonhosted.org/packages/source/P/PyKCS11/PyKCS11-1.5.11.tar.gz
+ sha256sums = ef1d51a24eff9eb6c1288428996614316841e34bac2d59f483db0ed1a9cad044
pkgname = python-pykcs11
-
diff --git a/PKGBUILD b/PKGBUILD
index 31ae219035bc..bf2405859c6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Vinicius Correa <vinicius dot correa at zoho dot com>
+
_pkgname=PyKCS11
pkgname=python-pykcs11
-pkgver=1.5.5
+pkgver=1.5.11
pkgrel=1
pkgdesc="PKCS#11 wrapper for Python."
-arch=('any')
-url="https://github.com/LudovicRousseau/${_pkgname}"
+arch=('x86_64')
+url="https://github.com/LudovicRousseau/pykcs11"
license=('GPL')
-depends=('python' 'swig')
-optdepends=()
-conflicts=()
-source=("https://github.com/LudovicRousseau/${_pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('7ad2bc49e4a122b7118494e04251b999')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'swig')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('ef1d51a24eff9eb6c1288428996614316841e34bac2d59f483db0ed1a9cad044')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir "$pkgdir" dist/*.whl
}