summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD30
-rw-r--r--pylibacl-0.5.3.tar.gz.sig16
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6448de3f39f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by aurpkgs
+# Sat Apr 29 23:55:07 UTC 2017
+pkgbase = python-pylibacl
+ pkgdesc = A python extension module that allows you to manipulate the POSIX.1e ACLs. (Fixed for python 3)
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = http://pylibacl.k1024.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = python
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/p/pylibacl/pylibacl-0.5.3.tar.gz
+ source = pylibacl-0.5.3.tar.gz.sig
+ sha512sums = 7d58a3a64e939a8891333a0fb8aa6e12dcbbf09e4e829f86fd1bb41693dd4f734a4ab907770e8e341476594aa495b5308a26d495ebf251dcda308ee46e5392ad
+ sha512sums = SKIP
+
+pkgname = python-pylibacl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b672d1367a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=python-pylibacl
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="A python extension module that allows you to manipulate the POSIX.1e ACLs. (Fixed for python 3)"
+arch=( 'i686' 'x86_64' )
+url="http://pylibacl.k1024.org/"
+license=( 'LGPL' )
+depends=( 'python' 'python2' )
+makedepends=( 'python-distribute' 'python2-distribute' 'python' 'python2' )
+_pkgname=python-pylibacl
+conflicts=( 'pkg''pkg')
+install=
+changelog=
+noextract=()
+source=("https://files.pythonhosted.org/packages/source/p/pylibacl/pylibacl-0.5.3.tar.gz"
+ "pylibacl-0.5.3.tar.gz.sig")
+sha512sums=('7d58a3a64e939a8891333a0fb8aa6e12dcbbf09e4e829f86fd1bb41693dd4f734a4ab907770e8e341476594aa495b5308a26d495ebf251dcda308ee46e5392ad'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}
diff --git a/pylibacl-0.5.3.tar.gz.sig b/pylibacl-0.5.3.tar.gz.sig
new file mode 100644
index 000000000000..72322c61b1c6
--- /dev/null
+++ b/pylibacl-0.5.3.tar.gz.sig
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCgAdFiEEdIIx68vYCKFPXoXSjABML5NIH2sFAlkFJ80ACgkQjABML5NI
+H2tdMhAAtoZWnv0vouYOWxmptomqcdH032wVWJFRwdEmYe+S/yjJdaRb2A1CYIa1
+l/+sYOBFwZukzJIYGjrxVJFEZbKbvVCdLzlqLqmATc55lhffNwPD8qewbxhSpKIz
+i1IJOvHekiTwvjvlJPt6Ayg03QE/IphUVq4sCyaom+vArl0cbKcnnNLUqk8ohGJX
+86GVocn2n7Lz7b77gJ99f/DDVM/uh02QhzIw+sEEYMU4HTpdZ2+DVZytulyJ/QnS
+iBMF9+YvLThU9aP+rZuJhe6mxtge0lp+BFm+a5YAjc+YTF6IWOKg2a4tIF5dyrCG
+eb1Nl38aMJgT2vi0ZdASnQHtbC830MaSNVYR3yTS/gJEW59NsCWpdYP0NSVKFsW2
+fgJsYvU0Yfqg1zF8oWh7YjYJe1u3cnKJK5SAzuLgMqGWh3MKLtS10CPcx/diX8s7
+tfH77UuffgqM8xnqJ+v8XSABrB8CXG+Bbocgu6vi4Y3R7pOj+TCi7oCg+LR1oFff
+/Z3/f/OoOCvmxYhPD5m5sAutvOTeRw7lHdUAQmdsmOiS+891VVic6vAZoaRG65og
+RD+sbjy9qpZxEgixNS56qaPSOgGz+PcEUfyNsWqQYpdkRfSrVXMVVEnpHyj94vaP
+9eHVn1wZHgJ5u3a1SYzv6P0i4dgjLvbSxY+BbDA6jZ/2cq95mcs=
+=moA6
+-----END PGP SIGNATURE-----