summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de8830f37839
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pylibconfig2
+ pkgdesc = Pure python library for libconfig syntax
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pylibconfig2
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ depends = python python-pyparsing
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/p/pylibconfig2/pylibconfig2-0.2.5.tar.gz
+ sha256sums = 186bd2d88356036ac8770195c8a3e9bac3ccdb3b9e6ecf04be62c307760895c7
+
+pkgname = python-pylibconfig2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acb9ca3bb268
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+_name='pylibconfig2'
+pkgname=python-$_name
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="Pure python library for libconfig syntax"
+arch=('any')
+url="http://pypi.python.org/pypi/${_name}"
+license=('GPLv3')
+makedepends=('python-setuptools')
+depends=('python python-pyparsing')
+options=(!emptydirs)
+
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('186bd2d88356036ac8770195c8a3e9bac3ccdb3b9e6ecf04be62c307760895c7')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}