summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98852703d4a7..357f58c83486 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = python-pylibjpeg-libjpeg
pkgdesc = A JPEG, JPEG-LS and JPEG XT plugin for pylibjpeg
- pkgver = 2.02
+ pkgver = 2.2.0
pkgrel = 1
+ epoch = 1
url = https://github.com/pydicom/pylibjpeg-libjpeg
arch = x86_64
- license = GPL
+ license = GPL-3.0-or-later
makedepends = git
makedepends = poetry
makedepends = python-installer
+ depends = gcc-libs
+ depends = glibc
depends = python-numpy
- source = python-pylibjpeg-libjpeg::git+https://github.com/pydicom/pylibjpeg-libjpeg.git#tag=v2.02
- sha512sums = SKIP
+ source = python-pylibjpeg-libjpeg::git+https://github.com/pydicom/pylibjpeg-libjpeg.git#tag=v2.2.0
+ sha512sums = 4b405e2e679595199d3bfaf39f9e41e222041d6d57a3baedf4a31fc8d6eb411875e95c24719c861df9706210d7bb220d0e14e28fd122f31a4313128679f210c6
pkgname = python-pylibjpeg-libjpeg
diff --git a/PKGBUILD b/PKGBUILD
index df54702004f9..f2462913a738 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,16 @@
_pkgname=pylibjpeg-libjpeg
pkgname=python-pylibjpeg-libjpeg
-pkgver=2.02
+pkgver=2.2.0
pkgrel=1
+epoch=1
pkgdesc='A JPEG, JPEG-LS and JPEG XT plugin for pylibjpeg'
arch=('x86_64')
url='https://github.com/pydicom/pylibjpeg-libjpeg'
-license=(GPL)
+license=('GPL-3.0-or-later')
depends=(
+ gcc-libs
+ glibc
python-numpy
)
makedepends=(
@@ -17,7 +20,7 @@ makedepends=(
python-installer
)
source=("${pkgname}::git+https://github.com/pydicom/pylibjpeg-libjpeg.git#tag=v${pkgver}")
-sha512sums=('SKIP')
+sha512sums=('4b405e2e679595199d3bfaf39f9e41e222041d6d57a3baedf4a31fc8d6eb411875e95c24719c861df9706210d7bb220d0e14e28fd122f31a4313128679f210c6')
prepare() {
cd "${pkgname}"