summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 998a76cccca3..e7afdf17e64a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pylint-celery
pkgdesc = pylint plugin for analyzing celery
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/landscapeio/pylint-celery
arch = any
license = GPL2
makedepends = python-setuptools
- depends = python
- source = https://github.com/landscapeio/pylint-celery/archive/d688f97c7da6ea729d7a632db28bb37fc4aadf94.tar.gz
- md5sums = 26051966e31fb9e8f4c127f935e424df
+ depends = python-pylint-plugin-utils
+ source = https://github.com/landscapeio/pylint-celery/archive/0.3.tar.gz
+ md5sums = b33388b34935ce0ccb7ff02aec0911f0
pkgname = python-pylint-celery
diff --git a/PKGBUILD b/PKGBUILD
index 0978f33f40a0..c75beaa2e450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-_pkgname=pylint-celery
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
pkgname=python-pylint-celery
+_pkgname=pylint-celery
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="pylint plugin for analyzing celery"
arch=('any')
url="https://github.com/landscapeio/pylint-celery"
license=('GPL2')
-depends=('python')
+depends=('python-pylint-plugin-utils')
makedepends=('python-setuptools')
-# Temp source override because there's not tag for 0.3
-source=(https://github.com/landscapeio/pylint-celery/archive/d688f97c7da6ea729d7a632db28bb37fc4aadf94.tar.gz)
-md5sums=('26051966e31fb9e8f4c127f935e424df')
+source=("$url/archive/$pkgver.tar.gz")
+md5sums=('b33388b34935ce0ccb7ff02aec0911f0')
build() {
- cd "${_pkgname}-"*
-
+ cd $srcdir/$_pkgname-$pkgver
python setup.py build
}
package() {
- cd "${_pkgname}-"*
-
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: