summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9da5fc936db..24b966c96ca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-pylint-django
pkgdesc = A Pylint plugin to help Pylint understand the Django web framework
- pkgver = 2.5.2
- pkgrel = 0
+ pkgver = 2.5.5
+ pkgrel = 2
url = https://github.com/landscapeio/pylint-django
arch = any
license = GPL2
- makedepends = python-setuptools
- makedepends = python-pylint-plugin-utils
- depends = python
- source = https://pypi.io/packages/source/p/pylint-django/pylint-django-2.5.2.tar.gz
- sha256sums = 1933d82b4a92538a3b12aef91adfd7d866befd051d7a02d6245b0f965587d97c
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry
+ depends = python-pylint
+ depends = python-pylint-plugin-utils
+ source = https://pypi.io/packages/source/p/pylint_django/pylint_django-2.5.5.tar.gz
+ sha256sums = 2f339e4bf55776958283395c5139c37700c91bd5ef1d8251ef6ac88b5abbba9b
pkgname = python-pylint-django
diff --git a/PKGBUILD b/PKGBUILD
index a704e3e60a79..e484db4acb2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
# Maintainer: Razer <razer@neuf.fr>
pkgname=python-pylint-django
-_pypi_pkgname=pylint-django
-pkgver=2.5.2
-pkgrel=0
+_pypi_pkgname=pylint_django
+pkgver=2.5.5
+pkgrel=2
pkgdesc="A Pylint plugin to help Pylint understand the Django web framework"
arch=('any')
url="https://github.com/landscapeio/pylint-django"
license=('GPL2')
-depends=('python')
-makedepends=('python-setuptools' 'python-pylint-plugin-utils')
+depends=(
+'python-pylint'
+'python-pylint-plugin-utils'
+)
+makedepends=(
+'python-build'
+'python-installer'
+'python-wheel'
+'python-poetry'
+)
source=("https://pypi.io/packages/source/p/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
-sha256sums=('1933d82b4a92538a3b12aef91adfd7d866befd051d7a02d6245b0f965587d97c')
+sha256sums=('2f339e4bf55776958283395c5139c37700c91bd5ef1d8251ef6ac88b5abbba9b')
build() {
cd "${_pypi_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pypi_pkgname}-${pkgver}"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm644 -t "$pkgdir/usr/share/license/$pkgname" LICENSE
}
# vim:set ts=2 sw=2 et: