summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dd5b7f24be4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pylint-django
+ pkgdesc = Pylint plugin for improving code analysis for when using Django
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/landscapeio/pylint-django
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/landscapeio/pylint-django/archive/0.7.1.tar.gz
+ md5sums = 66dd51ea91cffca8bab28b30a4fb99cb
+
+pkgname = python-pylint-django
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5f4796e1164
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+_pkgname=pylint-django
+pkgname=python-pylint-django
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="Pylint plugin for improving code analysis for when using Django"
+arch=('any')
+url="https://github.com/landscapeio/pylint-django"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+# source=(https://github.com/landscapeio/pylint-django/archive/${pkgver}.tar.gz)
+# Temp source override because there's not tag for 0.7.2
+source=(https://github.com/landscapeio/pylint-django/archive/e381721eedcaf240bf56b038878c1e7fad848183.tar.gz)
+md5sums=('2106197486ad595e192242221493df7f')
+
+build() {
+ cd "${_pkgname}-"*
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-"*
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: