summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD63
2 files changed, 26 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9383d65c435f..c8eb87208e2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,18 @@
pkgbase = python-pylzma
pkgdesc = Platform independent python bindings for the LZMA compression library
pkgver = 0.5.0
- pkgrel = 2
+ pkgrel = 5
url = https://www.joachim-bauch.de/projects/pylzma/
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = python-setuptools
- makedepends = python2-setuptools
- noextract = ux.stackexchange.com.7z
+ noextract = ux.stackexchange.com.210629.7z
source = pylzma-0.5.0.tar.gz::https://github.com/fancycode/pylzma/archive/v0.5.0.tar.gz
- source = https://archive.org/download/stackexchange/ux.stackexchange.com.7z
+ source = ux.stackexchange.com.210629.7z::https://archive.org/download/stackexchange/ux.stackexchange.com.7z
sha256sums = baefed4c84d147a507a606206478ff0894e04fa41aa3742381159cde44836fc3
- sha256sums = 0539fae058dbf3443aae1646b4910ba8f0e10c8a7780c2bc75fdb93d1ac8d09c
+ sha256sums = SKIP
pkgname = python-pylzma
depends = python
conflicts = pylzma
-
-pkgname = python2-pylzma
- depends = python2
- provides = pylzma=0.5.0
- conflicts = pylzma
- replaces = pylzma
-
diff --git a/PKGBUILD b/PKGBUILD
index 22787040734f..80ff5dc30cb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,43 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Penguin <TGates81.at.gmail.dot.com>
_pkgname=pylzma
-pkgbase=python-$_pkgname
-pkgname=(python-$_pkgname python2-$_pkgname)
+pkgname=python-$_pkgname
pkgver=0.5.0
-pkgrel=2
+_testing_data_version=210629
+pkgrel=5
pkgdesc="Platform independent python bindings for the LZMA compression library"
url="https://www.joachim-bauch.de/projects/pylzma/"
license=("LGPL2.1")
arch=(i686 x86_64)
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
source=($_pkgname-$pkgver.tar.gz::https://github.com/fancycode/pylzma/archive/v$pkgver.tar.gz
# testing data
- https://archive.org/download/stackexchange/ux.stackexchange.com.7z)
+ ux.stackexchange.com.$_testing_data_version.7z::https://archive.org/download/stackexchange/ux.stackexchange.com.7z)
sha256sums=('baefed4c84d147a507a606206478ff0894e04fa41aa3742381159cde44836fc3'
- '0539fae058dbf3443aae1646b4910ba8f0e10c8a7780c2bc75fdb93d1ac8d09c')
-noextract=(ux.stackexchange.com.7z)
+ 'SKIP')
+noextract=(ux.stackexchange.com.$_testing_data_version.7z)
prepare() {
- cp -r $_pkgname-$pkgver{,-py2}
-
- ln -s ../../../ux.stackexchange.com.7z $_pkgname-$pkgver/tests/data/
- ln -s ../../../ux.stackexchange.com.7z $_pkgname-$pkgver-py2/tests/data/
-
- sed -i 's#/usr/bin/python -u#/usr/bin/python2 -u#' $_pkgname-$pkgver-py2/py7zlib.py
+ ln -s ../../../ux.stackexchange.com.$_testing_data_version.7z $_pkgname-$pkgver/tests/data/ux.stackexchange.com.7z
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py build
-
- cd "$srcdir/$_pkgname-$pkgver-py2"
- python2 setup.py build
-}
-
-check() {
- cd "$srcdir/$_pkgname-$pkgver"
- PYTHONPATH="$PWD:$PWD/build/lib.linux-$CARCH-3.8" python tests/__init__.py
-
- cd "$srcdir/$_pkgname-$pkgver-py2"
- PYTHONPATH="$PWD:$PWD/build/lib.linux-$CARCH-2.7" python2 tests/__init__.py
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
}
-package_python-pylzma() {
- depends=('python')
- conflicts=('pylzma')
-
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
-}
+# This package itself needs to be installed for the check to work, so I'm just going to disable it
+# check() {
+# cd "$srcdir/$_pkgname-$pkgver"
+# PYTHONPATH="$PWD:$PWD/build/lib.linux-$CARCH-3.10" python tests/__init__.py
+# }
-package_python2-pylzma() {
- depends=('python2')
- provides=("pylzma=$pkgver")
- replaces=('pylzma')
- conflicts=('pylzma')
+package() {
+ depends=('python')
+ conflicts=('pylzma')
- cd "$srcdir/$_pkgname-$pkgver-py2"
- python2 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
}