summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD43
2 files changed, 18 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4199b175154..37d1f359c7c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-pymysql-git
pkgdesc = Pure Python MySQL Client
- pkgver = 20130105
+ pkgver = r538.cda58f0
pkgrel = 1
url = https://github.com/petehunt/PyMySQL
arch = any
- license = BSD
+ license = MIT
makedepends = git
makedepends = python-distribute
depends = python
+ provides = pymysql
conflicts = pymysql
+ source = python-pymysql-git::git+https://github.com/petehunt/PyMySQL
+ md5sums = SKIP
pkgname = python-pymysql-git
diff --git a/PKGBUILD b/PKGBUILD
index a7506d5b6a98..55ae69c50448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,24 @@
-# Maintainer: Allen Li <darkfeline@abagofapples.com>
+# Maintainer: Allen Li <darkfeline@felesatra.moe>
pkgname=python-pymysql-git
-pkgver=20130105
+pkgver=r538.cda58f0
pkgrel=1
pkgdesc="Pure Python MySQL Client"
arch=(any)
url="https://github.com/petehunt/PyMySQL"
-license=('GPL')
-license=('BSD')
+license=('MIT')
depends=('python')
makedepends=('git' 'python-distribute')
+provides=('pymysql')
conflicts=('pymysql')
+source=($pkgname'::git+https://github.com/petehunt/PyMySQL')
+md5sums=('SKIP')
-_gitroot="https://github.com/petehunt/PyMySQL"
-_gitname=pymysql
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- ./build-py3k.sh
- cd py3k
- python setup.py install --root="$pkgdir" --prefix=/usr
- install -Dm0644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir" --prefix=/usr
+}