summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f732fbd96f43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pynbody
+ pkgdesc = Pynbody is a light-weight, portable, format-transparent analysis framework for N-body and hydrodynamic astrophysical simulations
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://pynbody.github.io/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cython>=0.2
+ optdepends = python-matplotlib: plotting pynbody built-in plots
+ optdepends = ipython: makes using python much easier
+ source = https://github.com/pynbody/pynbody/archive/refs/tags/v1.1.0.tar.gz
+ sha256sums = fb5f9482bc27b0f3485dfd7cff5852068e923972364be531990a60da806deca9
+
+pkgname = python-pynbody
+ depends = python>=3.3
+ depends = python-numpy
+ depends = python-scipy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fabb982ca03e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lukasz Pozarlik <lpozarlik@gmail.com>
+
+pkgbase=python-pynbody
+pkgname=('python-pynbody')
+pkgdesc='Pynbody is a light-weight, portable, format-transparent analysis framework for N-body and hydrodynamic astrophysical simulations'
+pkgver=1.1.0
+pkgrel=1
+url="http://pynbody.github.io/"
+license=('MIT')
+arch=('any')
+makedepends=('git'
+ 'cython>=0.2')
+optdepends=('python-matplotlib: plotting pynbody built-in plots'
+ 'ipython: makes using python much easier')
+source=("https://github.com/pynbody/pynbody/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('fb5f9482bc27b0f3485dfd7cff5852068e923972364be531990a60da806deca9')
+
+package_python-pynbody() {
+ depends=('python>=3.3'
+ 'python-numpy'
+ 'python-scipy')
+ cd "${srcdir}/pynbody-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}