summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 36 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2603e67bd23..e2cb859de49c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-pyperformance
pkgdesc = Python Performance Benchmark Suite
- pkgver = 1.0.0
- pkgrel = 3
+ pkgver = 1.0.4
+ pkgrel = 1
url = https://github.com/python/pyperformance
arch = any
license = MIT
- checkdepends = python-tox
- makedepends = python-pip
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-sphinx
depends = python-pyperf
- depends = python-six
- source = https://pypi.org/packages/source/p/pyperformance/pyperformance-1.0.0.tar.gz
- sha256sums = 3aaaf52c6333e5d9275ec44040cda527b441318fe3866911339a59858fca3d90
+ depends = python-toml
+ depends = python-packaging
+ source = python-pyperformance-1.0.4.tar.gz::https://files.pythonhosted.org/packages/source/p/pyperformance/pyperformance-1.0.4.tar.gz
+ sha256sums = 759645cad9492be36301a7d2abeae564ef66e93539812a55e576839c81df80fa
pkgname = python-pyperformance
-
diff --git a/PKGBUILD b/PKGBUILD
index b5741a02f641..cee24245dc9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
-# Maintainer: hexchain <i at hexchain dot org>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: hexchain <i at hexchain dot org>
-_pypiname=pyperformance
-pkgname=python-$_pypiname
-pkgver=1.0.0
-pkgrel=3
+pkgname=python-pyperformance
+pkgver=1.0.4
+pkgrel=1
pkgdesc='Python Performance Benchmark Suite'
-url="https://github.com/python/pyperformance"
-depends=('python-pyperf' 'python-six')
-makedepends=('python-pip')
-checkdepends=('python-tox')
license=('MIT')
arch=('any')
-source=("https://pypi.org/packages/source/${_pypiname:0:1}/$_pypiname/$_pypiname-$pkgver.tar.gz")
-sha256sums=('3aaaf52c6333e5d9275ec44040cda527b441318fe3866911339a59858fca3d90')
+url="https://github.com/python/pyperformance"
+depends=('python-pyperf' 'python-toml' 'python-packaging')
+makedepends=(
+ 'python-setuptools'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-sphinx')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pyperformance/pyperformance-$pkgver.tar.gz")
+sha256sums=('759645cad9492be36301a7d2abeae564ef66e93539812a55e576839c81df80fa')
build() {
- cd "$srcdir/$_pypiname-$pkgver"
- python setup.py build
-}
-
-check() {
- cd "$srcdir/$_pypiname-$pkgver"
- tox -s true
+ cd "pyperformance-$pkgver"
+ python -m build --wheel --no-isolation
+ cd doc
+ make man
}
package() {
- cd "$srcdir/$_pypiname-$pkgver"
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
- install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ export PYTHONHASHSEED=0
+ cd "pyperformance-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 doc/build/man/pythonperformancebenchmarksuite.1 \
+ -t "$pkgdir/usr/share/man/man1/"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}