summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..334d25bbfbee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 20:13:46 UTC 2016
+pkgbase = python-pyquante2-git
+ pkgdesc = Python Quantum Chemistry Reloaded. This is a rewrite of the standard PyQuante program to clean up things that have been nagging me.
+ pkgver = r469.91a352b
+ pkgrel = 1
+ url = https://github.com/rpmuller/pyquante2
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python2
+ depends = python-numpy
+ depends = python2-numpy
+ depends = cython
+ depends = cython2
+ provides = python-pyquante2
+ provides = python2-pyquante2
+ conflicts = python-pyquante2
+ conflicts = python2-pyquante2
+ source = git+https://github.com/rpmuller/pyquante2
+ md5sums = SKIP
+
+pkgname = python-pyquante2-git
+ depends = python
+ depends = python-numpy
+ depends = cython
+ provides = python-pyquante2
+ conflicts = python-pyquante2
+
+pkgname = python2-pyquante2-git
+ depends = python2
+ depends = python2-numpy
+ depends = cython2
+ provides = python2-pyquante2
+ conflicts = python2-pyquante2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ddeb76bc0f90
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+pyquante2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..365fb8ecb633
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+
+_name=pyquante2
+pkgname=(python-${_name}-git python2-${_name}-git)
+pkgver=r469.91a352b
+pkgrel=1
+pkgdesc="Python Quantum Chemistry Reloaded. This is a rewrite of the standard PyQuante program to clean up things that have been nagging me."
+arch=("i686" "x86_64")
+url="https://github.com/rpmuller/${_name}"
+license=("BSD")
+depends=("python" "python2" "python-numpy" "python2-numpy" "cython" "cython2")
+makedepends=("git")
+provides=("python-pyquante2" "python2-pyquante2")
+conflicts=("python-pyquante2" "python2-pyquante2")
+source=("git+https://github.com/rpmuller/${_name}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package_python-pyquante2-git() {
+ depends=("python" "python-numpy" "cython")
+ provides=("python-pyquante2")
+ conflicts=("python-pyquante2")
+
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+package_python2-pyquante2-git() {
+ depends=("python2" "python2-numpy" "cython2")
+ provides=("python2-pyquante2")
+ conflicts=("python2-pyquante2")
+
+ cd "${srcdir}/${_name}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}