summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bdcf05f6383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyric
+ pkgdesc = Linux wireless library for the Python Wireless Developer and Pentester
+ pkgver = 0.1.6.3
+ pkgrel = 1
+ url = http://wraith-wireless.github.io/PyRIC/
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-twisted
+ source = https://pypi.python.org/packages/08/64/a99f27d3b4347486c7bfc0aa516016c46dc4c0f380ffccbd742a61af1eda/PyRIC-0.1.6.3.tar.gz
+ md5sums = c711069b2c1cb4fcc16312fed9b4d287
+
+pkgname = python-pyric
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a314c0812bb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: portaloffreedom
+
+_pkgsrcname=PyRIC
+pkgname=python-pyric
+pkgver=0.1.6.3
+pkgrel=1
+pkgdesc="Linux wireless library for the Python Wireless Developer and Pentester"
+url="http://wraith-wireless.github.io/PyRIC/"
+license=("MIT")
+arch=("any")
+depends=('python' 'python-twisted')
+source=("https://pypi.python.org/packages/08/64/a99f27d3b4347486c7bfc0aa516016c46dc4c0f380ffccbd742a61af1eda/PyRIC-$pkgver.tar.gz")
+
+md5sums=('c711069b2c1cb4fcc16312fed9b4d287')
+
+package() {
+ cd $srcdir/${_pkgsrcname}-$pkgver
+ python3 setup.py install --root $pkgdir
+ rm -rf $pkgdir/usr/lib/python3.6/site-packages/tests/
+}
+
+