summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f457f208d24..63f59b268f96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = python-pysdl2
pkgdesc = Python ctypes wrapper around SDL2
pkgver = 0.9.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/marcusva/py-sdl2
arch = any
- license = custom:CC0
+ license = https://github.com/marcusva/py-sdl2/blob/master/doc/copying.rst
depends = python
depends = sdl2
optdepends = sdl2_gfx
optdepends = sdl2_image
optdepends = sdl2_mixer
optdepends = sdl2_ttf
- source = https://pypi.python.org/packages/eb/08/8a81128ff6ca89019de9771425638bc197a28f40c1e377f03626baa5d729/PySDL2-0.9.6.tar.gz
- source = https://pypi.python.org/packages/eb/08/8a81128ff6ca89019de9771425638bc197a28f40c1e377f03626baa5d729/PySDL2-0.9.6.tar.gz.asc
- validpgpkeys = 8045642355B844E284606ED2F5645D06D1395E36
- sha256sums = b52acab5493a77b08c2afee1f385769fc2005f17cfeaf1886eff22dc78da2123
- sha256sums = 1ecf785e16a62f155cce557e8caa0ce373042c0d7f1993dc98083f32c25dfe1e
+ source = python-pysdl2-0.9.6.tar.gz::https://github.com/marcusva/py-sdl2/archive/rel_0_9_6.tar.gz
+ sha256sums = 50e137cc6078d20d59c7a79883a684a02cbeaa583c9f43ac6bfbcca364236f97
pkgname = python-pysdl2
diff --git a/PKGBUILD b/PKGBUILD
index 719c9882ab19..1eee382112b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,18 @@
pkgname=python-pysdl2
pkgver=0.9.6
-pkgrel=2
+pkgrel=3
pkgdesc="Python ctypes wrapper around SDL2"
-arch=('any')
-url="https://github.com/marcusva/py-sdl2"
-license=('custom:CC0')
-depends=('python' 'sdl2')
-optdepends=('sdl2_gfx' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
-_srcpath='eb/08/8a81128ff6ca89019de9771425638bc197a28f40c1e377f03626baa5d729'
-source=("https://pypi.python.org/packages/${_srcpath}/PySDL2-$pkgver.tar.gz"{,.asc})
-sha256sums=('b52acab5493a77b08c2afee1f385769fc2005f17cfeaf1886eff22dc78da2123'
- '1ecf785e16a62f155cce557e8caa0ce373042c0d7f1993dc98083f32c25dfe1e')
-validpgpkeys=('8045642355B844E284606ED2F5645D06D1395E36') # Marcus von Appen
+arch=("any")
+url="https://github.com/marcusva/${pkgname/python-py/py-}"
+license=("https://github.com/marcusva/${pkgname/python-py/py-}/blob/master/doc/copying.rst")
+depends=("python" "sdl2")
+optdepends=("sdl2_gfx" "sdl2_image" "sdl2_mixer" "sdl2_ttf")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/marcusva/${pkgname/python-py/py-}/archive/rel_${pkgver//./_}.tar.gz")
+sha256sums=("50e137cc6078d20d59c7a79883a684a02cbeaa583c9f43ac6bfbcca364236f97")
package() {
- cd PySDL2-$pkgver
- python setup.py install --root="$pkgdir"
- install -Dm644 doc/copying.rst "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd "${pkgname/python-py/py-}-rel_${pkgver//./_}"
+ python setup.py install --root="${pkgdir}"
+ install -Dm644 "doc/copying.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}