summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16c1f1f01c0e..4259890cadec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
pkgbase = python-pysim-git
pkgdesc = A python tool to program SIMs / USIMs / ISIMs
- pkgver = 1.0.r175.gb07a3e9
+ pkgver = 1.0.r520.g219a5f36
pkgrel = 1
- url = http://osmocom.org/projects/pysim/wiki
+ url = https://osmocom.org/projects/pysim/wiki
arch = any
license = GPL2
makedepends = python-setuptools
makedepends = git
depends = python
- depends = python-pyscard
- depends = python-pyserial
- depends = python-pytlv
+ depends = python-bidict
depends = python-cmd2>=1.3.0
- depends = python-jsonpath-ng
+ depends = python-colorlog
depends = python-construct>=2.9
- depends = python-bidict
depends = python-gsm0338
+ depends = python-jsonpath-ng
+ depends = python-pyscard
+ depends = python-pyserial
+ depends = python-pytlv
+ depends = python-termcolor
+ depends = python-yaml>=5.1
provides = python-pysim
source = git+https://git.osmocom.org/pysim
sha256sums = SKIP
pkgname = python-pysim-git
install = python-pysim-git.install
-
diff --git a/PKGBUILD b/PKGBUILD
index 284f9e5a9434..4e02fd0ac11d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer: Robert Falkenberg <robert.falkenberg@tu-dortmund.de>
+# Maintainer: Robert Falkenberg <falkenber9@gmail.com>
pkgname=python-pysim-git
-_pyname=pysim
-pkgver=1.0.r175.gb07a3e9
+_pyname=${pkgname#python-}
+_pyname=${_pyname%-git}
+pkgver=1.0.r520.g219a5f36
pkgrel=1
pkgdesc='A python tool to program SIMs / USIMs / ISIMs'
arch=('any')
-url='http://osmocom.org/projects/pysim/wiki'
+url='https://osmocom.org/projects/pysim/wiki'
license=('GPL2')
depends=('python'
+ 'python-bidict'
+ 'python-cmd2>=1.3.0'
+ 'python-colorlog'
+ 'python-construct>=2.9'
+ 'python-gsm0338'
+ 'python-jsonpath-ng'
'python-pyscard'
'python-pyserial'
'python-pytlv'
- 'python-cmd2>=1.3.0'
- 'python-jsonpath-ng'
- 'python-construct>=2.9'
- 'python-bidict'
- 'python-gsm0338')
+ 'python-termcolor'
+ 'python-yaml>=5.1')
makedepends=('python-setuptools' 'git')
provides=('python-pysim')
source=('git+https://git.osmocom.org/pysim')