summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ebb6db4028a..49ab8397a0b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyspf
pkgdesc = Python implementation of the Sender Policy Framework (SPF) protocol
- pkgver = 2.0.11
+ pkgver = 2.0.12
pkgrel = 1
url = http://pypi.python.org/pypi/pyspf
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-pyspf
makedepends = python-setuptools
depends = python-pydns
optdepends = python-authres: Return RFC 5451 Authentication Results headers
- source = http://pypi.python.org/packages/source/p/pyspf/pyspf-2.0.11.tar.gz
- md5sums = 83add3a0d8732bcc28841ceb5da440ba
+ source = http://pypi.python.org/packages/source/p/pyspf/pyspf-2.0.12t.tar.gz
+ md5sums = c83143ad79074bf8c80235748a8a698f
pkgname = python-pyspf
diff --git a/PKGBUILD b/PKGBUILD
index d8a16665d15e..973320b977c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Rich Li <rich at dranek com>
# Contributor: Samed Beyribey <ras0ir AT eventualis DOT org>
pkgname=python-pyspf
-pkgver=2.0.11
+pkgver=2.0.12
+# This version is a patched release that is only reflected in the filename; this will likely be removed in the next upstream release?
+_fix_pkgver=2.0.12t
pkgrel=1
pkgdesc="Python implementation of the Sender Policy Framework (SPF) protocol"
arch=('any')
@@ -10,15 +12,9 @@ license=('PSF')
depends=('python-pydns')
makedepends=('python-setuptools')
optdepends=('python-authres: Return RFC 5451 Authentication Results headers')
-source=(http://pypi.python.org/packages/source/p/pyspf/pyspf-$pkgver.tar.gz)
-md5sums=('83add3a0d8732bcc28841ceb5da440ba')
+source=(http://pypi.python.org/packages/source/p/pyspf/pyspf-$_fix_pkgver.tar.gz)
+md5sums=('c83143ad79074bf8c80235748a8a698f')
-# NOTE from the maintainer: 2.0.12 is available, but as of 2015-08-10 is
-# completely broken due to using tab-indentation for a few lines. The script
-# will not run in Python 3. The indentation is ambiguous, so that I cannot
-# correct it myself. I sent an email to pyspf@openspf.org on 2015-08-10 to
-# notify them of the issue.
-
build() {
cd "$srcdir/pyspf-$pkgver"
python setup.py build