summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19e16143ab54..9dcfe6a0147d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-pysqlcipher3
- pkgdesc = DB-API 2.0 interface for SQLCIPHER 3.x
- pkgver = 1.0.2
- pkgrel = 1
+ pkgdesc = Python 3 bindings for SQLCipher (project no longer maintained. Vulnerabilities may exist)
+ pkgver = 1.0.3
+ pkgrel = 2
url = https://github.com/rigglemania/pysqlcipher3
arch = any
license = ZLIB
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/p/pysqlcipher3/pysqlcipher3-1.0.2.tar.gz
- md5sums = 387aa1f10ff84b72d879c111c6fce3d7
+ depends = sqlcipher
+ source = https://files.pythonhosted.org/packages/source/p/pysqlcipher3/pysqlcipher3-1.0.3.tar.gz
+ sha256sums = 694e5bbb6ece8a064bd55f261e54b9ffbb3af1784afdc4dce4948a0251a8a430
pkgname = python-pysqlcipher3
- depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 056daf2a102e..0edc9403f6d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-pkgbase=('python-pysqlcipher3')
-pkgname=('python-pysqlcipher3')
-_module='pysqlcipher3'
-pkgver='1.0.2'
-pkgrel=1
-pkgdesc="DB-API 2.0 interface for SQLCIPHER 3.x"
-url="https://github.com/rigglemania/pysqlcipher3"
-depends=('python')
+# Contributor: RcrdBrt
+# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=python-pysqlcipher3
+_pkgname=${pkgname#python-}
+pkgver=1.0.3
+pkgrel=2
+pkgdesc='Python 3 bindings for SQLCipher (project no longer maintained. Vulnerabilities may exist)'
+arch=('any')
+url='https://github.com/rigglemania/pysqlcipher3'
+depends=('python' 'sqlcipher')
makedepends=('python-setuptools')
license=('ZLIB')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/p/pysqlcipher3/pysqlcipher3-${pkgver}.tar.gz")
-md5sums=('387aa1f10ff84b72d879c111c6fce3d7')
+source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('694e5bbb6ece8a064bd55f261e54b9ffbb3af1784afdc4dce4948a0251a8a430')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}