summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28de59372d87..98f6864213d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 7 13:25:06 UTC 2018
+# Mon Jan 7 12:04:26 UTC 2019
pkgbase = python-pytest-xvfb
pkgdesc = Pytest plugin to run Xvfb for tests
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/The-Compiler/pytest-xvfb
arch = i686
@@ -12,8 +12,8 @@ pkgbase = python-pytest-xvfb
depends = python>=3.3
depends = python-pytest>=2.8.1
depends = python-pyvirtualdisplay>=0.2.1
- source = https://files.pythonhosted.org/packages/source/p/pytest-xvfb/pytest-xvfb-1.1.0.tar.gz
- md5sums = 0754da6fb2ed04cb1604eec8c0a3deea
+ source = https://files.pythonhosted.org/packages/source/p/pytest-xvfb/pytest-xvfb-1.2.0.tar.gz
+ md5sums = a5e43fe3926c55b03fc12f4f149f059d
pkgname = python-pytest-xvfb
diff --git a/PKGBUILD b/PKGBUILD
index 3a4353cea0be..7f0d8da3f008 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-xvfb
-pkgver=1.1.0
+_pyname=${pkgname#python-}
+pkgver=1.2.0
pkgrel=1
pkgdesc="Pytest plugin to run Xvfb for tests"
arch=('i686' 'x86_64')
@@ -8,11 +9,11 @@ url="https://github.com/The-Compiler/pytest-xvfb"
license=('MIT')
depends=('python>=3.3' 'python-pytest>=2.8.1' 'python-pyvirtualdisplay>=0.2.1')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/p/pytest-xvfb/pytest-xvfb-${pkgver}.tar.gz")
-md5sums=('0754da6fb2ed04cb1604eec8c0a3deea')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('a5e43fe3926c55b03fc12f4f149f059d')
package() {
- cd ${srcdir}/pytest-xvfb-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"