summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 024d7940850c..cdb5493d8afb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pytmx
pkgdesc = Python library to read Tiled Map Editor's TMX maps
- pkgver = 3.22.0
- pkgrel = 2
+ pkgver = 3.31
+ pkgrel = 1
url = https://github.com/bitcraft/PyTMX
arch = i686
arch = x86_64
@@ -11,8 +11,7 @@ pkgbase = python-pytmx
depends = python-six
provides = python-pytmx
conflicts = python-pytmx
- source = git+https://github.com/bitcraft/PyTMX.git#commit=1896511afff65b5a5eb18295976ec44b68a9bb5a
+ source = git+https://github.com/bitcraft/PyTMX.git#commit=2ef7dcac8526d9b5085c147b70b1078666542f12
sha256sums = SKIP
pkgname = python-pytmx
-
diff --git a/PKGBUILD b/PKGBUILD
index 967881c458a9..7f31da6944d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: morguldir <morguldir@protonmail.com>
_gitname=PyTMX
pkgname=python-pytmx
-pkgver=3.22.0
-pkgrel=2
+pkgver=3.31
+_commit=2ef7dcac8526d9b5085c147b70b1078666542f12
+pkgrel=1
pkgdesc="Python library to read Tiled Map Editor's TMX maps"
arch=('i686' 'x86_64')
url="https://github.com/bitcraft/$_gitname"
@@ -11,10 +12,15 @@ depends=('python>=3.3' 'python-six')
makedepends=('git')
provides=($pkgname)
conflicts=($pkgname)
-source=("git+https://github.com/bitcraft/$_gitname.git#commit=1896511afff65b5a5eb18295976ec44b68a9bb5a")
+source=("git+https://github.com/bitcraft/$_gitname.git#commit=$_commit")
sha256sums=('SKIP')
package(){
- cd $_gitname
+ cd "$srcdir"/$_gitname
python setup.py install --root="$pkgdir" --prefix=/usr
}
+
+check() {
+ cd "$srcdir"/$_gitname
+ python -m unittest tests/pytmx/test_pytmx.py
+}