summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD24
4 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7593aa1b9c9..bf6d2e558331 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = python-pyviz_comms
pkgdesc = Bidirectional communication for the PyViz ecosystem
- pkgver = 2.2.1
+ pkgver = 3.0.2
pkgrel = 1
url = https://github.com/pyviz/pyviz_comms
arch = any
- license = custom:BSD-3-clause
- makedepends = python-setuptools
+ license = BSD-3-Clause
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-hatch-nodejs-version
+ makedepends = python-hatch-jupyter-builder
+ makedepends = python-wheel
depends = python-param
- source = pyviz_comms-2.2.1.tar.gz::https://github.com/pyviz/pyviz_comms/archive/v2.2.1.tar.gz
- sha512sums = 7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e
+ depends = jupyterlab
+ source = https://pypi.org/packages/source/p/pyviz_comms/pyviz_comms-3.0.2.tar.gz
+ sha512sums = fc7fe018754b808fe3b7e04db2c576b7a456a3c1468b4ff483542ebe5aefecb251a7a34fe7e0d55e84594cdde76c8c7842880372124c588319667120fc9106df
pkgname = python-pyviz_comms
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..d31f146f94fc
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-pyviz_comms]
+source = "github"
+github = "pyviz/pyviz_comms"
+use_latest_release = "true"
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 8755d474c297..d4a86d9da254 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,25 @@
# Contributor: jerry73204 <jerry73204 at google gmail>
_base=pyviz_comms
pkgname=python-${_base}
-pkgver=2.2.1
+pkgdesc="Bidirectional communication for the PyViz ecosystem"
+pkgver=3.0.2
pkgrel=1
-pkgdesc='Bidirectional communication for the PyViz ecosystem'
arch=(any)
url="https://github.com/pyviz/${_base}"
-license=('custom:BSD-3-clause')
-makedepends=(python-setuptools)
-depends=(python-param)
-# checkdepends=(python-pytest flake8)
-source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e')
+license=(BSD-3-Clause)
+depends=(python-param jupyterlab)
+makedepends=(python-build python-installer python-hatch-nodejs-version python-hatch-jupyter-builder python-wheel)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('fc7fe018754b808fe3b7e04db2c576b7a456a3c1468b4ff483542ebe5aefecb251a7a34fe7e0d55e84594cdde76c8c7842880372124c588319667120fc9106df')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-# check() {
-# cd ${_base}-${pkgver}
-# python -m pytest
-# }
-
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}