summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7593aa1b9c9..0001f1ddb3dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = python-pyviz_comms
pkgdesc = Bidirectional communication for the PyViz ecosystem
pkgver = 2.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pyviz/pyviz_comms
arch = any
license = custom:BSD-3-clause
+ checkdepends = python-pytest
makedepends = python-setuptools
depends = python-param
+ depends = jupyterlab
source = pyviz_comms-2.2.1.tar.gz::https://github.com/pyviz/pyviz_comms/archive/v2.2.1.tar.gz
sha512sums = 7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e
diff --git a/PKGBUILD b/PKGBUILD
index 8755d474c297..549826acdc81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,27 @@
_base=pyviz_comms
pkgname=python-${_base}
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Bidirectional communication for the PyViz ecosystem'
arch=(any)
url="https://github.com/pyviz/${_base}"
license=('custom:BSD-3-clause')
makedepends=(python-setuptools)
-depends=(python-param)
-# checkdepends=(python-pytest flake8)
+depends=(python-param jupyterlab)
+checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e')
build() {
cd ${_base}-${pkgver}
python setup.py build
+ jlpm
}
-# check() {
-# cd ${_base}-${pkgver}
-# python -m pytest
-# }
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest
+}
package() {
cd ${_base}-${pkgver}