summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD20
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c60eda885bd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pywatchman
+ pkgdesc = Watchman client for python
+ pkgver = 1.4.1
+ pkgrel = 0
+ url = https://github.com/facebook/watchman
+ arch = x86_64
+ license = Apache
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ optdepends = watchman
+ source = https://pypi.python.org/packages/source/p/pywatchman/pywatchman-1.4.1.tar.gz
+ md5sums = d770d09bd105e83013f63492fce70c6f
+
+pkgname = python-pywatchman
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..140a02266036
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.log
+*.log.[0-9]
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f25015ca4d57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+#Maintainer Reto <reto@labrat.space>
+pkgname='python-pywatchman'
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Watchman client for python"
+url="https://github.com/facebook/watchman"
+depends=('python')
+optdepends=('watchman')
+license=('Apache')
+arch=('x86_64')
+makedepends=('python' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/p/pywatchman/pywatchman-$pkgver.tar.gz")
+
+package() {
+ cd "$srcdir/pywatchman-$pkgver"
+ python setup.py build
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+md5sums=('d770d09bd105e83013f63492fce70c6f')