summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--0001-optional-pyinstaller.patch20
-rw-r--r--PKGBUILD10
4 files changed, 12 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe5f801c6fd..02ad3edbc967 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
- pkgver = 1.3.0
+ pkgver = 1.7.1
pkgrel = 1
url = https://github.com/kitao/pyxel
arch = i686
@@ -14,10 +14,7 @@ pkgbase = python-pyxel
depends = python-sounddevice
depends = sdl2_image
optdepends = pyinstaller
- source = https://github.com/kitao/pyxel/archive/v1.3.0.tar.gz
- source = 0001-optional-pyinstaller.patch
- md5sums = deb168ddd6154f76d1483cf8dcfced67
- md5sums = 1e9509ebffc17ed518dbec3a34b8ed21
+ source = https://github.com/kitao/pyxel/archive/v1.7.1.tar.gz
+ md5sums = 276d57dc3899c994e4e49b6265fe0eb1
pkgname = python-pyxel
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82c7472909dc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+*.tar.zst
+pkg
+src
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
deleted file mode 100644
index fed4fde63d23..000000000000
--- a/0001-optional-pyinstaller.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 91b4bdb..6b45047 100644
---- a/setup.py
-+++ b/setup.py
-@@ -40,12 +40,13 @@ setuptools.setup(
- "pyxel.examples.assets",
- ],
- package_data={"": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so"]},
-- install_requires=["pyinstaller"],
-+ install_requires=[],
-+ extras_require={"packager": ["pyinstaller"]},
- python_requires=">=3.7",
- entry_points={
- "console_scripts": [
- "pyxeleditor=pyxel.editor:run",
-- "pyxelpackager=pyxel.packager:run",
-+ "pyxelpackager=pyxel.packager:run [packager]",
- "install_pyxel_examples=pyxel.examples:install",
- ]
- },
diff --git a/PKGBUILD b/PKGBUILD
index 6b9f7f8d5b84..8c69fc871498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=python-pyxel
-pkgver=1.3.0
+pkgver=1.7.1
pkgrel=1
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
@@ -12,15 +12,13 @@ depends=('portaudio' 'python-glfw' 'python-opengl'
'python-pillow' 'python-sounddevice' 'sdl2_image')
optdepends=('pyinstaller')
makedepends=('python-setuptools')
-source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
- "0001-optional-pyinstaller.patch")
-md5sums=('deb168ddd6154f76d1483cf8dcfced67'
- '1e9509ebffc17ed518dbec3a34b8ed21')
+source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz")
+md5sums=('276d57dc3899c994e4e49b6265fe0eb1')
build() {
cd pyxel-$pkgver
- patch -i "$srcdir"/0001-optional-pyinstaller.patch
+ #patch -i "$srcdir"/0001-optional-pyinstaller.patch
python setup.py build
}