summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore6
2 files changed, 26 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..cf06dd3ed5ab
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[.gitattributes]
+indent_size = 16
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dab3f9ea524c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/.vscode
+/src
+/pkg
+*.pkg.*
+*.tar.*
+*.zip