summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38bd57017021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-quandl-git
+ pkgdesc = Wrapper for quandl-python
+ pkgver = v3.1.0.r0.g1d06fe5
+ pkgrel = 1
+ url = https://github.com/quandl/quandl-python
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python>=3.6
+ provides = python-quandl
+ source = python-quandl::git+https://github.com/quandl/quandl-python.git
+ md5sums = SKIP
+
+pkgname = python-quandl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ae1883fff98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: vsilv <vsilv@posteo.eu>
+# Maintainer : vsilv <vsilv@posteo.eu>
+pkgname=python-quandl-git
+pkgver=v3.1.0.r0.g1d06fe5
+pkgrel=1
+pkgdesc="Wrapper for quandl-python"
+arch=('x86_64')
+url="https://github.com/quandl/quandl-python"
+license=('MIT')
+depends=('python>=3.6')
+makedepends=('git')
+provides=('python-quandl')
+source=('python-quandl::git+https://github.com/quandl/quandl-python.git')
+
+md5sums=('SKIP')
+_gitname='python-quandl'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+build() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --prefix=/usr --root=${pkgdir} -O1 --skip-build
+}
+