summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d6f95a47985
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-quantlib
+ pkgdesc = A Python binding for QuantLib.
+ pkgver = 1.8
+ pkgrel = 1
+ url = http://quantlib.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = make
+ makedepends = gcc
+ depends = quantlib=1.8
+ depends = python
+ options = !libtool
+ source = http://downloads.sourceforge.net/project/quantlib/QuantLib/1.8/other%20languages/QuantLib-SWIG-1.8.tar.gz
+ md5sums = 32a0cfb3ec049a6af86fc864e4616c1f
+
+pkgname = python-quantlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c30fd322cf58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Hao Zhang <theivorytower [at] gmail [dot] com>
+
+pkgname=python-quantlib
+_pkgname=QuantLib-SWIG
+pkgver=1.8
+pkgrel=1
+pkgdesc="A Python binding for QuantLib."
+arch=("i686" "x86_64")
+url="http://quantlib.org"
+license=("BSD")
+options=(!libtool)
+depends=("quantlib=$pkgver" "python")
+makedepends=("make" "gcc")
+source=(http://downloads.sourceforge.net/project/quantlib/QuantLib/$pkgver/other%20languages/$_pkgname-$pkgver.tar.gz)
+md5sums=("32a0cfb3ec049a6af86fc864e4616c1f")
+
+build() {
+ cd "$srcdir"/"$_pkgname-$pkgver"/
+ ./configure --prefix=/usr
+ make -C Python
+}
+
+package() {
+ cd "$srcdir"/"$_pkgname-$pkgver"/
+ sed -i "s#setup.py install#setup.py install --root=\"${pkgdir}\"#g" Python/Makefile
+ make -C Python install
+}