summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d162a187c6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-redbaron
+ pkgdesc = Abstraction on top of baron, a FST for python to make writing refactoring code a realistic task
+ pkgver = 0.9.2
+ pkgrel = 8
+ url = https://github.com/PyCQA/redbaron
+ arch = any
+ license = LGPL
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = python-pypandoc
+ depends = python-baron
+ source = python-redbaron-0.9.2.tar.gz::https://github.com/PyCQA/redbaron/archive/0.9.2.tar.gz
+ source = python-redbaron-pytest-4.patch::https://github.com/PyCQA/redbaron/commit/812081b7bd8774ceb61016ac37da43107c26eea2.patch
+ sha512sums = acebde8fcf5fea419960c2647e8251deb6ea9426e886d642d58ee29924f668a8359867cec934aa10a0eeedf511b454a5f9e603458355869989e3b168165d6f6a
+ sha512sums = 0c3170116217dd989890850e3f8f6c05c25494a1d843185b4f40d682de76bc6ced58a852d5c34db6e572c491e2fa4a0f764766c3db543bdf25af147f2813fcb8
+
+pkgname = python-redbaron
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91eb53d6c3f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python-redbaron
+pkgver=0.9.2
+pkgrel=8
+pkgdesc="Abstraction on top of baron, a FST for python to make writing refactoring code a realistic task"
+url="https://github.com/PyCQA/redbaron"
+license=('LGPL')
+arch=('any')
+depends=('python-baron')
+makedepends=('python-setuptools' 'python-pypandoc')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/PyCQA/redbaron/archive/$pkgver.tar.gz"
+ $pkgname-pytest-4.patch::https://github.com/PyCQA/redbaron/commit/812081b7bd8774ceb61016ac37da43107c26eea2.patch)
+sha512sums=('acebde8fcf5fea419960c2647e8251deb6ea9426e886d642d58ee29924f668a8359867cec934aa10a0eeedf511b454a5f9e603458355869989e3b168165d6f6a'
+ '0c3170116217dd989890850e3f8f6c05c25494a1d843185b4f40d682de76bc6ced58a852d5c34db6e572c491e2fa4a0f764766c3db543bdf25af147f2813fcb8')
+
+prepare() {
+ patch -d redbaron-$pkgver -p1 < $pkgname-pytest-4.patch
+}
+
+build() {
+ cd redbaron-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd redbaron-$pkgver
+ pytest tests
+}
+
+package() {
+ cd redbaron-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}