summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 25 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e572a2163a4..cbfe1f83cc41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Sep 9 07:53:25 UTC 2018
+# Wed Dec 5 18:49:28 UTC 2018
pkgbase = python-regions
pkgdesc = Astropy affilated package for region handling
pkgver = 0.3
@@ -8,14 +8,9 @@ pkgbase = python-regions
arch = i686
arch = x86_64
license = BSD
- checkdepends = python-pytest-astropy
- checkdepends = python-astropy-healpix
makedepends = cython
makedepends = python-astropy>=1.2
makedepends = python-astropy-helpers
- makedepends = python-sphinx
- makedepends = python-matplotlib
- makedepends = python-shapely
source = https://files.pythonhosted.org/packages/source/r/regions/regions-0.3.tar.gz
md5sums = b2f0b08cdaa2b40519de665f9af2a25a
@@ -25,8 +20,5 @@ pkgname = python-regions
depends = python-astropy>=1.2
optdepends = python-matplotlib>=1.5: Plotting support
optdepends = python-shapely: Managing geometric objects
- optdepends = python-regions-doc: Documentation for AstroPy Regions
-
-pkgname = python-regions-doc
- pkgdesc = Documentation for AstroPy Regions
+ optdepends = python-pytest-astropy: For testing
diff --git a/PKGBUILD b/PKGBUILD
index 5e0811156cdf..f50dc1b95302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
-pkgbase=python-regions
-pkgname=('python-regions' 'python-regions-doc')
+#pkgbase=python-regions
+pkgname=('python-regions')
+#'python-regions-doc')
pkgver=0.3
pkgrel=1
pkgdesc="Astropy affilated package for region handling"
arch=('i686' 'x86_64')
url="http://astropy-regions.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('cython' 'python-astropy>=1.2' 'python-astropy-helpers' 'python-sphinx' 'python-matplotlib' 'python-shapely')
-checkdepends=('python-pytest-astropy' 'python-astropy-healpix')
+makedepends=('cython' 'python-astropy>=1.2' 'python-astropy-helpers')
+#'python-sphinx' 'python-matplotlib' 'python-shapely')
+#checkdepends=('python-pytest-astropy' 'python-astropy-healpix')
source=("https://files.pythonhosted.org/packages/source/r/regions/regions-${pkgver}.tar.gz")
md5sums=('b2f0b08cdaa2b40519de665f9af2a25a')
@@ -18,34 +20,35 @@ prepare() {
sed -i -e '/auto_use/s/True/False/' setup.cfg
}
-build () {
+build() {
cd ${srcdir}/regions-${pkgver}
python setup.py build --use-system-libraries --offline
- msg "Building Docs"
- python setup.py build_docs
+# msg "Building Docs"
+# python setup.py build_docs
}
-check(){
- cd ${srcdir}/regions-${pkgver}
-
- python setup.py test
-}
+#check() {
+# cd ${srcdir}/regions-${pkgver}
+#
+# python setup.py test
+#}
package_python-regions() {
depends=('python>=3.4' 'python-numpy>=1.9' 'python-astropy>=1.2')
optdepends=('python-matplotlib>=1.5: Plotting support'
'python-shapely: Managing geometric objects'
- 'python-regions-doc: Documentation for AstroPy Regions')
+# 'python-regions-doc: Documentation for AstroPy Regions'
+ 'python-pytest-astropy: For testing')
cd ${srcdir}/regions-${pkgver}
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
}
-package_python-regions-doc() {
- pkgdesc="Documentation for AstroPy Regions"
- cd ${srcdir}/regions-${pkgver}/build/sphinx
-
- install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
- cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
-}
+#package_python-regions-doc() {
+# pkgdesc="Documentation for AstroPy Regions"
+# cd ${srcdir}/regions-${pkgver}/build/sphinx
+#
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}