summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--ebec469f4baa.diff36
3 files changed, 5 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05d236a6bfe8..c75735d38cd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-relatorio
pkgdesc = A templating library able to output odt and pdf files
- pkgver = 0.9.1
+ pkgver = 0.9.2
pkgrel = 1
url = http://relatorio.tryton.org/
arch = any
license = GPL
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://pypi.io/packages/source/r/relatorio/relatorio-0.9.1.tar.gz
- sha512sums = 1bbbf08f1003f94f18f35c0ed2d3ba9064d336c26997d96231f6523218941d926bc259caa8912f049fc6262649c0a1ebb38c8dbc3740be1d730abe69e5118964
+ source = https://pypi.io/packages/source/r/relatorio/relatorio-0.9.2.tar.gz
+ sha512sums = 7e686dc7beb9296e320b0bd7806faffba63e623f79ac8eee520c1820f82c5dabaaa0f31b89773b2be9e70f407ed1764ef1f56b9e265d145514a24b1944795511
pkgname = python-relatorio
depends = python-genshi>=0.5
diff --git a/PKGBUILD b/PKGBUILD
index fcf4a3a652b9..a18b56344804 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Florian Walch <florian.walch@gmx.at>
# Maintainer: Robin Baumgartner <robin@baumgartners.ch>
pkgname=('python-relatorio' 'python2-relatorio')
-pkgver=0.9.1
+pkgver=0.9.2
pkgrel=1
pkgdesc="A templating library able to output odt and pdf files"
arch=('any')
@@ -10,7 +10,7 @@ url="http://relatorio.tryton.org/"
license=('GPL')
makedepends=('python-setuptools' 'python2-setuptools')
source=("https://pypi.io/packages/source/r/relatorio/relatorio-$pkgver.tar.gz")
-sha512sums=('1bbbf08f1003f94f18f35c0ed2d3ba9064d336c26997d96231f6523218941d926bc259caa8912f049fc6262649c0a1ebb38c8dbc3740be1d730abe69e5118964')
+sha512sums=('7e686dc7beb9296e320b0bd7806faffba63e623f79ac8eee520c1820f82c5dabaaa0f31b89773b2be9e70f407ed1764ef1f56b9e265d145514a24b1944795511')
prepare() {
cp -a relatorio-$pkgver{,-py2}
diff --git a/ebec469f4baa.diff b/ebec469f4baa.diff
deleted file mode 100644
index 1e228d5ac642..000000000000
--- a/ebec469f4baa.diff
+++ /dev/null
@@ -1,36 +0,0 @@
-
-# HG changeset patch
-# User Cédric Krier <ced@b2ck.com>
-# Date 1570791867 -7200
-# Node ID ebec469f4baa9523522bb5a81113bf9a381bfc87
-# Parent e1b70835bc9eaa1af25f390ead9dee50c8fbf8fe
-Support file-magic as fallback to python-magic
-
-bug53
-
-diff -r e1b70835bc9e -r ebec469f4baa CHANGES
---- a/CHANGES Mon Jul 29 16:12:32 2019 +0200
-+++ b/CHANGES Fri Oct 11 13:04:27 2019 +0200
-@@ -1,3 +1,5 @@
-+* Support file-magic as fallback to python-magic
-+
- 0.9.0 - 20190729
- * Support out parameter of render
- * Write opendocument stream directly to the ZipFile
-diff -r e1b70835bc9e -r ebec469f4baa relatorio/templates/opendocument.py
---- a/relatorio/templates/opendocument.py Mon Jul 29 16:12:32 2019 +0200
-+++ b/relatorio/templates/opendocument.py Fri Oct 11 13:04:27 2019 +0200
-@@ -950,7 +950,11 @@
- binary_data, = image.xpath(
- './office:binary-data', namespaces=namespaces)
- data = base64.b64decode(binary_data.text)
-- mime_type = magic.from_buffer(data, mime=True)
-+ if hasattr(magic, 'from_buffer'):
-+ mime_type = magic.from_buffer(data, mime=True)
-+ else:
-+ # Not python-magic but file-magic
-+ mime_type = magic.detect_from_content(data).mime_type
- name = 'Pictures/image%s%s' % (
- i, mimetypes.guess_extension(mime_type))
- image.remove(binary_data)
-