summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da115e0f70cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-requests-gpgauthlib
+ pkgdesc = A GPGAuth Client in Python
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/liip/requests_gpgauthlib
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/liip/requests_gpgauthlib/archive/0.1.2.tar.gz
+ sha512sums = 5ca9a0bc9af081623cf868ff259e71c866f3e653c60ba576a9cd687f641469c8f45de2633dceeb7c17e842ab426cacb0b21706cc9e16b1de26f4843a0e42f071
+
+pkgname = python-requests-gpgauthlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14ef913fb773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+
+pkgname=python-requests-gpgauthlib
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='A GPGAuth Client in Python'
+arch=(any)
+url='https://github.com/liip/requests_gpgauthlib'
+license=(GPL3)
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/liip/requests_gpgauthlib/archive/${pkgver}.tar.gz")
+sha512sums=('5ca9a0bc9af081623cf868ff259e71c866f3e653c60ba576a9cd687f641469c8f45de2633dceeb7c17e842ab426cacb0b21706cc9e16b1de26f4843a0e42f071')
+
+build() {
+ cd requests_gpgauthlib-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd requests_gpgauthlib-${pkgver}
+ NO_THIRD_PARTY=true python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+}