summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 871aa860886b..bfb57128ab27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-resize-image
pkgdesc = A Small python package to easily resize images
pkgver = 1.1.19
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/VingtCinq/python-resize-image
arch = any
license = MIT
@@ -10,7 +10,9 @@ pkgbase = python-resize-image
makedepends = python2
makedepends = python2-setuptools
source = https://pypi.io/packages/source/p/python-resize-image/python-resize-image-1.1.19.tar.gz
+ source = https://raw.githubusercontent.com/VingtCinq/python-resize-image/master/LICENSE
sha256sums = 2aea25e9811fd44d4cb8fef82059ace114f6cc72bbef059f69b0b7f79f55e03e
+ sha256sums = bf3a8525e859c6ce1c4b6b463f65ffbe331480aae194c63e896a56d4d7708f08
pkgname = python-resize-image
depends = python-requests
diff --git a/.gitignore b/.gitignore
index 7c6927b4669a..5c0c85c13755 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg/*
src/*
*.tar.*
+LICENSE \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 9348f5469f29..56a04088467b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@
pkgbase='python-resize-image'
pkgname=('python-resize-image' 'python2-resize-image')
pkgver='1.1.19'
-pkgrel='1'
+pkgrel='2'
pkgdesc="A Small python package to easily resize images"
arch=("any")
url="https://github.com/VingtCinq/${pkgname}"
makedepends=('python' 'python-setuptools'
'python2' 'python2-setuptools')
license=('MIT')
-source=("https://pypi.io/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('2aea25e9811fd44d4cb8fef82059ace114f6cc72bbef059f69b0b7f79f55e03e')
+source=("https://pypi.io/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/VingtCinq/${pkgbase}/master/LICENSE")
+sha256sums=('2aea25e9811fd44d4cb8fef82059ace114f6cc72bbef059f69b0b7f79f55e03e'
+ 'bf3a8525e859c6ce1c4b6b463f65ffbe331480aae194c63e896a56d4d7708f08')
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
@@ -24,6 +26,7 @@ package_python-resize-image() {
cd "${srcdir}/${pkgbase}-${pkgver}"
python setup.py install -O1 --root="${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
package_python2-resize-image() {
@@ -31,4 +34,5 @@ package_python2-resize-image() {
cd "${srcdir}/${pkgbase}-${pkgver}"
python2 setup.py install -O1 --root="${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}