summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1b43111aa09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-retdec-python
+ pkgdesc = A Python library and tools providing easy access to the retdec.com decompilation service through their public REST API.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/s3rvac/retdec-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/r/retdec-python/retdec-python-0.5.2.tar.gz
+ md5sums = d6b3c37bc26bd116896d4dc23c8a9432
+
+pkgname = python-retdec-python
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4307bcb1b65b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mathieu Clabaut <mathieu[at]clabaut.net>
+pkgbase=('python-retdec-python')
+pkgname=('python-retdec-python')
+_module='retdec-python'
+pkgver='0.5.2'
+pkgrel=1
+pkgdesc="A Python library and tools providing easy access to the retdec.com decompilation service through their public REST API."
+url="https://github.com/s3rvac/retdec-python"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/r/retdec-python/retdec-python-${pkgver}.tar.gz")
+md5sums=('d6b3c37bc26bd116896d4dc23c8a9432')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ # conflict with leptonica fileinfo
+ mv ${pkgdir}/usr/bin/fileinfo ${pkgdir}/usr/bin/retdec-fileinfo
+
+}