summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--CHANGELOG.md114
-rw-r--r--PKGBUILD53
4 files changed, 157 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a534c381a35..eaac68e1f571 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = python-ripser
- pkgdesc = nested sampling visualisation
- pkgver = 0.4.1
+ pkgdesc = A Lean Persistent Homology Library for Python
+ pkgver = 0.6.8
pkgrel = 1
url = https://github.com/scikit-tda/ripser.py
- arch = any
+ changelog = CHANGELOG.md
+ arch = x86_64
license = MIT
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
makedepends = cython
- depends = python
- depends = cython
- depends = python-numpy
- depends = python-scipy
- depends = python-scikit-learn
depends = python-persim
- options = !emptydirs
- source = https://github.com/scikit-tda/ripser.py/archive/v0.4.1.tar.gz
- sha256sums = ec7f34935f5e6d3430c7f5a27007ccf4f50a21936d4045c0d3aa1e77209ef8fa
+ source = ripser.py-0.6.8.tar.gz::https://github.com/scikit-tda/ripser.py/archive/v0.6.8.tar.gz
+ sha512sums = 86e5f5aeee23428374197ebee7d582e0e61c01acdc8860f1ac089993efb62d400dbfca21a920f9911c603e7604d8ee4f803bd89b1a3cbc5750d4a876fab6aca0
pkgname = python-ripser
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..4fb420d03e89
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,114 @@
+# 0.6.8
+
+ - Update CD commands for newer build system.
+
+# 0.6.7
+
+ - Failed to build wheels. This version does not exist.
+
+# 0.6.6
+
+ - Failed to build wheels. This version does not exist.
+
+# 0.6.5
+
+ - Bugfix for lower star filtrations with edges that come in at exactly 0 (courtesy of Riccardo Ceccaroni)
+
+# 0.6.4
+
+ - Add some includes to ripser.cpp for newer Ubuntu/C++ environments
+
+# 0.6.3
+
+ - Update numpy header
+
+# 0.6.2
+
+ - Prevent simplex assembly in last dimension for improved memory usage (courtesy of Umberto Lupo)
+
+# 0.6.1
+
+ - Lazy import plotting dependencies
+
+# 0.6.0
+
+ - Update C++ backend to commit 286d369 of [ripser](https://github.com/Ripser/ripser) but keeping same functionalities
+ - Add support to robinhood hashmap into the C++ Backend
+ - Update CI in order to compile C++ with robinhood enable
+ - Enable Enclosing radius when threshold is set to infinity
+
+# 0.5.5
+
+ - Updating CI/CD pipeline.
+
+# 0.5.4
+
+ - Fixing issue with inconsistent answers from different scipy.sparse formats, courtesy of Umberto Lupo
+
+# 0.5.3
+
+ - Adding link to ripser++ GPU version by Simon Zhang
+
+# 0.5.2:
+
+ - Cocycle indices now correspond to point cloud indices, even
+ when a greedy permutation is in use
+
+# 0.4.1:
+
+ - Fixed packing so C++ is MSVC compatible.
+
+# 0.4.0:
+
+ - Added license to distributed packages.
+
+# 0.3.2:
+
+ - Added support for greedy permutations.
+ - Outsourced plotting to persim.
+ - Outsourced data construction in examples to tadasets.
+ - Revamped documentation.
+
+# 0.3.0:
+
+ - Completed JOSS review, thanks @lmcinnes and @arokem!!
+ - Documentation details updated.
+
+# 0.2.7:
+
+ - Updating home url
+
+# 0.2.6:
+
+ - Update license to MIT.
+
+# 0.2.5:
+
+ - Docs and notebooks revamp.
+ - Support for Windows.
+
+# 0.2.4:
+
+ - Interface redesign
+
+# 0.2.3:
+
+ - Support for lower star filtrations
+ - Notebook on lower star filtrations
+
+# 0.2.1:
+
+ - Sparse distance matrix support
+ - Two additional notebooks about sparsity
+ - Language agnostic bindings support
+ - Bug fixes (filtrations with low number of points)
+
+# 0.2.0:
+
+ - Bug fixes (int rounding error for small magnitude threshold)
+
+# 0.1.7:
+
+ - Generation of cocycles.
+ - Handle inf in C code and in plotting.
+ - Many new options for plotting diagrams.
diff --git a/PKGBUILD b/PKGBUILD
index 322aadc7b58b..13466dd7bc84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,35 @@
-# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=ripser
-pkgname=python-$_modulename
-pkgver=0.4.1
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_base=ripser
+pkgname=python-${_base}
+pkgver=0.6.8
pkgrel=1
-pkgdesc="nested sampling visualisation"
-arch=(any)
-url="https://github.com/scikit-tda/ripser.py"
-license=('MIT')
-groups=()
-depends=('python' 'cython' 'python-numpy' 'python-scipy' 'python-scikit-learn' 'python-persim')
-makedepends=('python-setuptools' 'cython')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('ec7f34935f5e6d3430c7f5a27007ccf4f50a21936d4045c0d3aa1e77209ef8fa')
+pkgdesc="A Lean Persistent Homology Library for Python"
+arch=(x86_64)
+url="https://github.com/scikit-tda/${_base}.py"
+license=(MIT)
+depends=(python-persim)
+makedepends=(python-build python-installer python-setuptools python-wheel cython)
+checkdepends=(python-pytest)
+changelog=CHANGELOG.md
+source=(${_base}.py-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('86e5f5aeee23428374197ebee7d582e0e61c01acdc8860f1ac089993efb62d400dbfca21a920f9911c603e7604d8ee4f803bd89b1a3cbc5750d4a876fab6aca0')
+
+build() {
+ cd ${_base}.py-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}.py-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
+}
+
package() {
- cd "$srcdir/${_modulename}.py-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd ${_base}.py-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}