summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dafb0f93440
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Jan 19 02:32:37 UTC 2016
+pkgbase = python-rivescript-git
+ pkgdesc = Rendering Intelligence Very Easily
+ pkgver = 85.182b564
+ pkgrel = 1
+ url = https://github.com/aichaos/rivescript-python
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = python-six
+ depends = python2-six
+ depends = python-setuptools
+ depends = python2-setuptools
+ conflicts = python-rivescript
+ source = git+https://github.com/aichaos/rivescript-python.git
+ md5sums = SKIP
+
+pkgname = python-rivescript-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d23501e6217
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Trevor <assviolat0r at live dot com>
+
+pkgname=python-rivescript-git
+pkgver=85.182b564
+pkgrel=1
+pkgdesc="Rendering Intelligence Very Easily"
+arch=('any')
+license=('MIT')
+depends=('python2' 'python-six' 'python2-six' 'python-setuptools' 'python2-setuptools')
+conflicts=('python-rivescript')
+makedepends=('git')
+url='https://github.com/aichaos/rivescript-python'
+source=('git+https://github.com/aichaos/rivescript-python.git')
+md5sums=('SKIP')
+_gitname=rivescript-python
+
+pkgver () {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git describe --always | sed 's/-/./g')
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 || return 1
+}