summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 47 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 592e9850fbb3..840bb7d476b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,14 +5,24 @@ pkgbase = python-rosdistro
url = http://wiki.ros.org/rosdistro
arch = any
license = BSD
- makedepends = python
makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/r/rosdistro/rosdistro-0.6.2.tar.gz
+ md5sums = 5ef1af890d0fc92c6920c4c86ef498cd
+
+pkgname = python-rosdistro
+ depends =
depends = python
+ depends = python-catkin_pkg
+ depends = python-rospkg
+ depends = python-yaml
conflicts = python2-rosdistro
- source = http://download.ros.org/downloads/rosdistro/rosdistro-0.6.2.tar.gz
- source = https://raw.githubusercontent.com/ros-infrastructure/rosdistro/f6a87bf67a39c64ed962c3f79d7b45256e0c14a7/LICENSE.txt
- sha256sums = 834776e7419465b23080b099ddb3b981fbe8623442ed2b446989f3fa998fb178
- sha256sums = 32aac2a1d3abb4c6ee1c0a973f6337874228d459a2565c5ad4c6a4dc46e84b3b
-pkgname = python-rosdistro
+pkgname = python2-rosdistro
+ depends =
+ depends = python2
+ depends = python2-catkin_pkg
+ depends = python2-rospkg
+ depends = python2-yaml
+ conflicts = python-rosdistro
diff --git a/PKGBUILD b/PKGBUILD
index 8d0ce41f7ec3..b16777d3c7b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,41 @@
-#Automatically generated by pip2arch on 2014-06-09
+# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgname=python-rosdistro
-pkgver=0.6.2
+pkgbase=('python-rosdistro')
+pkgname=('python-rosdistro' 'python2-rosdistro')
+_module='rosdistro'
+pkgver='0.6.2'
pkgrel=1
pkgdesc="A tool to work with rosdistro files"
-arch=('any')
url="http://wiki.ros.org/rosdistro"
+depends=()
+makedepends=('python-setuptools' 'python2-setuptools')
license=('BSD')
-depends=('python')
-makedepends=('python' 'python-setuptools')
-source=("http://download.ros.org/downloads/rosdistro/rosdistro-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/ros-infrastructure/rosdistro/f6a87bf67a39c64ed962c3f79d7b45256e0c14a7/LICENSE.txt")
-sha256sums=('834776e7419465b23080b099ddb3b981fbe8623442ed2b446989f3fa998fb178'
- '32aac2a1d3abb4c6ee1c0a973f6337874228d459a2565c5ad4c6a4dc46e84b3b')
-conflicts=(python2-rosdistro)
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/r/rosdistro/rosdistro-${pkgver}.tar.gz")
+md5sums=('5ef1af890d0fc92c6920c4c86ef498cd')
+
+prepare() {
+ cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
+}
build() {
- cd rosdistro-$pkgver
- python setup.py build
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-rosdistro() {
+ depends+=('python' 'python-catkin_pkg' 'python-rospkg' 'python-yaml')
+ conflicts=('python2-rosdistro')
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-package() {
- cd rosdistro-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 ../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+package_python2-rosdistro() {
+ depends+=('python2' 'python2-catkin_pkg' 'python2-rospkg' 'python2-yaml')
+ conflicts=('python-rosdistro')
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}