summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 454be9807585..d82670bfd5ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-rospkg
- pkgdesc = ROS package library
- pkgver = 1.1.7
+ pkgdesc = Standalone Python library for the ROS package system
+ pkgver = 1.5.0
pkgrel = 1
- url = http://wiki.ros.org/rospkg
+ url = https://github.com/ros-infrastructure/rospkg
arch = any
license = BSD
makedepends = python-setuptools
depends = python
+ depends = python-catkin_pkg
+ depends = python-distro
depends = python-yaml
conflicts = python2-rospkg
- source = https://files.pythonhosted.org/packages/source/r/rospkg/rospkg-1.1.7.tar.gz
- md5sums = a5b9c6d6b8e101ff2d29e2335afdadab
+ source = https://github.com/ros-infrastructure/rospkg/archive/1.5.0.tar.gz
+ sha256sums = 6290b6ffb69aec9c00178345ddc9036aaecf29ca3bc17ba21eee63d9d4d8ff31
pkgname = python-rospkg
-
diff --git a/PKGBUILD b/PKGBUILD
index aa2e419605bf..cff10288d421 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-rospkg'
pkgname=('python-rospkg')
-_module='rospkg'
-pkgver='1.1.7'
+pkgver='1.5.0'
pkgrel=1
-pkgdesc="ROS package library"
-url="http://wiki.ros.org/rospkg"
-depends=('python' 'python-yaml')
-conflicts=('python2-rospkg')
-makedepends=('python-setuptools')
-license=('BSD')
+pkgdesc='Standalone Python library for the ROS package system'
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/r/rospkg/rospkg-${pkgver}.tar.gz")
-md5sums=('a5b9c6d6b8e101ff2d29e2335afdadab')
+url='https://github.com/ros-infrastructure/rospkg'
+license=('BSD')
+depends=('python' 'python-catkin_pkg' 'python-distro' 'python-yaml')
+makedepends=('python-setuptools')
+
+conflicts=('python2-rospkg')
+source=("https://github.com/ros-infrastructure/rospkg/archive/${pkgver}.tar.gz")
+sha256sums=('6290b6ffb69aec9c00178345ddc9036aaecf29ca3bc17ba21eee63d9d4d8ff31')
+
+_module='rospkg'
build() {
cd "${srcdir}/${_module}-${pkgver}"