summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d5ed67ca10d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-sabctools
+ pkgdesc = implements three main sets of C implementations that are used within SABnzbd
+ pkgver = 7.0.1
+ pkgrel = 1
+ url = https://github.com/sabnzbd/sabctools/
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/sabctools/sabctools-7.0.1.tar.gz
+ sha512sums = 5c6b883a3f7c851355298f0cc65b412b97a35d5335c5a3db783e82d8eb8e77ca89c4c3e861edee66051e9f960829dcf9986324750e0bd3632c4f14383b371eb3
+
+pkgname = python-sabctools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e570bc49abe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+*.log
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f4bb8e54767
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Alex Brinister <alex_brinister at yahoo dot com>
+
+pkgbase=python-sabctools
+pkgname='python-sabctools'
+_name=sabctools
+pkgver=7.0.1
+pkgrel=1
+pkgdesc="implements three main sets of C implementations that are used within SABnzbd"
+arch=('any')
+url="https://github.com/sabnzbd/sabctools/"
+license=(GPL2)
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('5c6b883a3f7c851355298f0cc65b412b97a35d5335c5a3db783e82d8eb8e77ca89c4c3e861edee66051e9f960829dcf9986324750e0bd3632c4f14383b371eb3')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}