summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD10
3 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d69503642f6..f5cf119c49a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Feb 10 04:01:00 UTC 2017
+# Mon Feb 27 01:13:17 UTC 2017
pkgbase = python-sanic
pkgdesc = A microframework based on uvloop, httptools, and learnings of flask
- pkgver = 0.3.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/channelcat/sanic
arch = any
license = MIT
makedepends = python-setuptools
- source = https://github.com/channelcat/sanic/archive/0.3.1.tar.gz
- sha256sums = c8abb954c4e1bef749bf683f4502357cd65c5ae9eec91f92d84fe9d177728067
+ source = https://files.pythonhosted.org/packages/source/s/sanic/sanic-0.4.0.tar.gz
+ source = https://raw.githubusercontent.com/channelcat/sanic/0.4.0/LICENSE
+ sha256sums = fdfd31ff44441e04ba32e38503ec430996d45f18cf2dbeb0e15fec9cdfd09991
+ sha256sums = a406579cd136771c705c521db86ca7d60a6f3de7c9b5460e6193a2df27861bde
pkgname = python-sanic
depends = python-uvloop>=0.5.3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f98512bb47e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.pkg.tar.xz
+*-build.log
+*-package.log
+*-namcap.log
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 42e9dc6b3adb..af3f2ad2e47e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
_name="sanic"
pkgname="python-$_name"
-pkgver=0.3.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="A microframework based on uvloop, httptools, and learnings of flask"
arch=("any")
url="https://github.com/channelcat/sanic"
license=("MIT")
makedepends=("python-setuptools")
-source=("https://github.com/channelcat/sanic/archive/$pkgver.tar.gz")
-sha256sums=('c8abb954c4e1bef749bf683f4502357cd65c5ae9eec91f92d84fe9d177728067')
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/channelcat/sanic/$pkgver/LICENSE")
+sha256sums=('fdfd31ff44441e04ba32e38503ec430996d45f18cf2dbeb0e15fec9cdfd09991'
+ 'a406579cd136771c705c521db86ca7d60a6f3de7c9b5460e6193a2df27861bde')
build() {
cd "$_name-$pkgver"
@@ -24,5 +26,5 @@ package() {
"python-aiofiles>=0.3.0")
cd "$_name-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/LICENSE"
}