summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD49
3 files changed, 45 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f47f66428551..eaea389af13f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-scikit-bio
pkgdesc = Python package providing data structures, algorithms, and educational resources for bioinformatics
- pkgver = 0.5.5
- pkgrel = 2
+ pkgver = 0.5.6
+ pkgrel = 1
url = https://github.com/biocore/scikit-bio
arch = x86_64
license = BSD
@@ -21,9 +21,11 @@ pkgbase = python-scikit-bio
depends = python-requests
depends = python-cachecontrol
depends = python-msgpack
+ depends = python-scikit-learn
+ depends = python-hdmedians
options = !emptydirs
- source = https://github.com/biocore/scikit-bio/archive/0.5.5.tar.gz
- md5sums = e8ec41366d9eeda9bce3ec43c2af1159
+ source = python-scikit-bio-0.5.6.tar.gz::https://github.com/biocore/scikit-bio/archive/0.5.6.tar.gz
+ sha256sums = 69cf88626ff3803625aa65c7f6792f431318bd31f2b4d5c79e9a71cfc29c37ea
pkgname = python-scikit-bio
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27fd112126d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 025595927e16..57a0ceabc9a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,48 @@
# Maintainer: Fabio Zanini <fabio.zanini _at_ fastmail.fm>
-pkgname='python-scikit-bio'
-pkgver=0.5.5
-pkgrel=2
+pkgname=python-scikit-bio
+pkgver=0.5.6
+pkgrel=1
pkgdesc="Python package providing data structures, algorithms, and educational resources for bioinformatics"
arch=('x86_64')
url="https://github.com/biocore/scikit-bio"
license=('BSD')
-groups=()
-depends=('python' 'python-future' 'python-decorator' 'python-six' 'python-contextlib2' 'python-natsort' 'python-bz2file' 'python-lockfile' 'python-pandas' 'python-scipy' 'python-numpy' 'python-matplotlib' 'python-requests' 'python-cachecontrol' 'python-msgpack')
+depends=(
+python
+python-future
+python-decorator
+python-six
+python-contextlib2
+python-natsort
+python-bz2file
+python-lockfile
+python-pandas
+python-scipy
+python-numpy
+python-matplotlib
+python-requests
+python-cachecontrol
+python-msgpack
+python-scikit-learn
+python-hdmedians
+)
makedepends=('python-setuptools')
-conflicts=()
-replaces=()
-backup=()
options=(!emptydirs)
-install=
-source=("https://github.com/biocore/scikit-bio/archive/${pkgver}.tar.gz")
-md5sums=('e8ec41366d9eeda9bce3ec43c2af1159')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/biocore/scikit-bio/archive/${pkgver}.tar.gz")
+sha256sums=('69cf88626ff3803625aa65c7f6792f431318bd31f2b4d5c79e9a71cfc29c37ea')
+
+build() {
+ cd scikit-bio-${pkgver}
+ python setup.py build
+}
+
+check(){
+ cd scikit-bio-${pkgver}
+ python setup.py test || :
+}
package() {
- cd "$srcdir/scikit-bio-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd scikit-bio-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: