summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a526e7befb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jul 22 17:36:57 UTC 2016
+pkgbase = python-scikit-bio
+ pkgdesc = Python package providing data structures, algorithms, and educational resources for bioinformatics
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://github.com/biocore/scikit-bio
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-future
+ depends = python-six
+ depends = python-contextlib2
+ depends = python-bz2file
+ depends = python-requests
+ depends = python-cachecontrol
+ options = !emptydirs
+ source = https://github.com/biocore/scikit-bio/archive/0.4.2.tar.gz
+ md5sums = e4f60f4e91e5464ce2458589d7b3e915
+
+pkgname = python-scikit-bio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3491c42b4e5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Fabio Zanini <fabio.zanini _at_ fastmail.fm>
+pkgname='python-scikit-bio'
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Python package providing data structures, algorithms, and educational resources for bioinformatics"
+arch=('x86_64')
+url="https://github.com/biocore/scikit-bio"
+license=('BSD')
+groups=()
+depends=('python' 'python-future' 'python-six' 'python-contextlib2' 'python-bz2file' 'python-requests' 'python-cachecontrol')
+makedepends=('python-setuptools')
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://github.com/biocore/scikit-bio/archive/${pkgver}.tar.gz")
+md5sums=('e4f60f4e91e5464ce2458589d7b3e915')
+
+package() {
+ cd "$srcdir/scikit-bio-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: