summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcafd03ff073..c0ad8a6220cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Feb 25 20:16:43 UTC 2016
pkgbase = python-scikit-sparse
pkgdesc = Scikit sparse matrix package
- pkgver = 0.3
+ pkgver = 0.4.4
pkgrel = 1
url = https://pypi.python.org/pypi/scikit-sparse/
- arch = i686
arch = x86_64
license = GPL
+ checkdepends = python-nose
+ makedepends = cython
depends = python-scipy
depends = suitesparse
- source = https://pypi.python.org/packages/source/s/scikit-sparse/scikit-sparse-0.3.tar.gz
- md5sums = edd0f3eaed471fe53ca4b0c03acc4ab3
+ source = https://pypi.python.org/packages/source/s/scikit-sparse/scikit-sparse-0.4.4.tar.gz
+ sha256sums = e9e6741ab0a43f43071e123d7d6250c9d60373308e55f0a0c5488b8eec4df319
pkgname = python-scikit-sparse
diff --git a/PKGBUILD b/PKGBUILD
index 4f3005c8a31a..fed89200c7fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
-
+# Maintainer: Guillaume Horel <guillaume dot horel at gmail dot com>
+# Contributor: Antony Lee <anntzer dot lee at gmail dot com>
_pyname=scikit-sparse
pkgname=python-$_pyname
-pkgver=0.3
+pkgver=0.4.4
pkgrel=1
pkgdesc='Scikit sparse matrix package'
url="https://pypi.python.org/pypi/$_pyname/"
+checkdepends=('python-nose')
depends=('python-scipy' 'suitesparse')
+makedepends=('cython')
license=('GPL')
-arch=('i686' 'x86_64')
+arch=('x86_64')
source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
-md5sums=('edd0f3eaed471fe53ca4b0c03acc4ab3')
+sha256sums=('e9e6741ab0a43f43071e123d7d6250c9d60373308e55f0a0c5488b8eec4df319')
build() {
cd $srcdir/$_pyname-$pkgver
@@ -21,3 +23,9 @@ package() {
cd $srcdir/$_pyname-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
}
+
+check() {
+ cd "${srcdir}/$_pyname-$pkgver"
+ python setup.py build_ext --inplace
+ nosetests
+}