summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b6f87625909..53da65f3e855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,11 +8,6 @@ pkgbase = python-scikit-surprise-git
makedepends = git
makedepends = python-setuptools
makedepends = cython
- makedepends = python-numpy
- source = git+https://github.com/NicolasHug/Surprise
- sha512sums = SKIP
-
-pkgname = python-scikit-surprise-git
depends = python-joblib
depends = python-numpy
depends = python-scipy
@@ -25,3 +20,7 @@ pkgname = python-scikit-surprise-git
optdepends = python-sphinxcontrib-spelling: spelling extension for documentation generator
provides = python-scikit-surprise=1.0.4.r112.gef3ed6e
conflicts = python-scikit-surprise
+ source = git+https://github.com/NicolasHug/Surprise
+ sha512sums = SKIP
+
+pkgname = python-scikit-surprise-git
diff --git a/PKGBUILD b/PKGBUILD
index c1f01234a2ca..4de5f626e4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,16 @@ pkgdesc="Python scikit for building and analyzing recommender systems"
arch=('any')
license=('BSD-3-Clause')
url="https://github.com/NicolasHug/${_reponame}"
-depends=()
-makedepends=('git' 'python-setuptools' 'cython' 'python-numpy')
-provides=()
-conflicts=()
+depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
+optdepends=("flake8: code linting to comply with contributing standards"
+ "python-pandas: dataframe handling"
+ "python-pytest: test suite"
+ "python-sphinx: documentation generator"
+ "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
+ "python-sphinxcontrib-spelling: spelling extension for documentation generator")
+makedepends=('git' 'python-setuptools' 'cython')
+provides=("python-scikit-surprise=${pkgver}")
+conflicts=("python-scikit-surprise")
source=("git+https://github.com/NicolasHug/${_reponame}")
sha512sums=('SKIP')
@@ -31,16 +37,6 @@ build() {
}
package() {
- depends=('python-joblib' 'python-numpy' 'python-scipy' 'python-six')
- optdepends=("flake8: code linting to comply with contributing standards"
- "python-pandas: dataframe handling"
- "python-pytest: test suite"
- "python-sphinx: documentation generator"
- "python-sphinx_rtd_theme: Read The Docs theme for documentation generator"
- "python-sphinxcontrib-spelling: spelling extension for documentation generator")
- provides=("python-scikit-surprise=${pkgver}")
- conflicts=("python-scikit-surprise")
-
cd "${srcdir}/${_reponame}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
ln -s surprise "${pkgdir}/usr/bin/surprise3"