summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 27 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cadfdd8075f2..46d42e9712d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = python-scipy-mkl
pkgdesc = SciPy is open-source software for mathematics, science, and engineering.
- pkgver = 1.5.4
+ pkgver = 1.8.1
pkgrel = 1
url = http://www.scipy.org/
arch = x86_64
license = BSD
+ checkdepends = python-pytest
+ makedepends = cython
+ makedepends = gcc-fortran
makedepends = pybind11
+ makedepends = python-pythran
makedepends = python-setuptools
- depends = intel-compiler-base
- depends = intel-fortran-compiler
- depends = intel-mkl
+ depends = intel-oneapi-compiler
+ depends = intel-oneapi-mkl
depends = python-numpy
optdepends = python-pillow: for image saving module
- provides = python-scipy=1.5.4
+ provides = python-scipy=1.8.1
conflicts = python-scipy
- source = https://github.com/scipy/scipy/releases/download/v1.5.4/scipy-1.5.4.tar.gz
- source = build.sh
- sha512sums = d23f68911a8880f87767819750d4d175ba8f9c72fcb9b8080305ee65722c046d4485fde4f0c85cc53c46247dd99813afe675a38b3b0569a683ddc2c2e021b8fc
- sha512sums = 1ad168482bd4774e47af009f888a549233defe5593b7464f3f5577a25ebec180905c948ebf3936c33ac49f2ea8cba5dcd060f8b86adb99ed2f1fc41fd2bf82bf
+ source = https://github.com/scipy/scipy/releases/download/v1.8.1/scipy-1.8.1.tar.gz
+ sha256sums = 9e3fb1b0e896f14a85aa9a28d5f755daaeeb54c897b746df7a55ccb02b340f33
pkgname = python-scipy-mkl
-
diff --git a/PKGBUILD b/PKGBUILD
index fa9f5de54ee2..6eba3657e1f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,49 +6,39 @@
# Contributor: Bodor Dávid Gábor <david.gabor.bodor@gmail.com>
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
-pkgname='python-scipy-mkl'
-pkgver=1.5.4
+pkgname=python-scipy-mkl
+pkgver=1.8.1
pkgrel=1
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
arch=('x86_64')
url="http://www.scipy.org/"
license=('BSD')
-depends=('intel-compiler-base' 'intel-fortran-compiler' 'intel-mkl' 'python-numpy')
+depends=('intel-oneapi-compiler' 'intel-oneapi-mkl' 'python-numpy')
provides=("python-scipy=$pkgver")
conflicts=('python-scipy')
-makedepends=('pybind11' 'python-setuptools')
-#checkdepends=('python-pytest')
+makedepends=('cython' 'gcc-fortran' 'pybind11' 'python-pythran' 'python-setuptools')
+checkdepends=('python-pytest')
optdepends=('python-pillow: for image saving module')
-source=("https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz" 'build.sh')
-sha512sums=('d23f68911a8880f87767819750d4d175ba8f9c72fcb9b8080305ee65722c046d4485fde4f0c85cc53c46247dd99813afe675a38b3b0569a683ddc2c2e021b8fc'
- '1ad168482bd4774e47af009f888a549233defe5593b7464f3f5577a25ebec180905c948ebf3936c33ac49f2ea8cba5dcd060f8b86adb99ed2f1fc41fd2bf82bf')
+source=("https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz")
+sha256sums=('9e3fb1b0e896f14a85aa9a28d5f755daaeeb54c897b746df7a55ccb02b340f33')
build() {
- export LDFLAGS="-Wall -shared"
- #export __INTEL_PRE_CFLAGS="-I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++ -I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++/x86_64-pc-linux-gnu/"
-
+ source /opt/intel/oneapi/setvars.sh
cd scipy-${pkgver}
- sh ${srcdir}/build.sh
+ python setup.py config_fc build
}
-#check() {
-# # we need to do a temp install so we can import scipy
-# # also, the tests must not be run from the scipy source directory
-# export LDFLAGS="-Wall -shared"
-#
-# cd ${srcdir}/scipy-${pkgver}
-# python3 setup.py config_fc --fcompiler=intelem install \
-# --prefix=/usr --root=${srcdir}/test --optimize=1
-# export PYTHONPATH=${srcdir}/test/usr/lib/python3.7/site-packages
-# cd ${srcdir}
-# python -c "from scipy import test; test('full')"
-#}
+check() {
+ cd ${srcdir}/scipy-${pkgver}
+ python3 setup.py config_fc install --prefix=/usr --root=${srcdir}/test --optimize=1
+ export PYTHONPATH=${srcdir}/test/usr/lib/python3.10/site-packages
+ cd ${srcdir}
+ python -c "from scipy import test; test('full')"
+}
package() {
- export LDFLAGS="-Wall -shared"
-
cd scipy-${pkgver}
- python3 setup.py config --compiler=intelem --fcompiler=intelem install --prefix=/usr --root="${pkgdir}/" --optimize=1
+ python3 setup.py config_fc install --prefix=/usr --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}