summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0aa277d29f5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sendfile
+ pkgdesc = A Python interface to sendfile(2)
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/giampaolo/pysendfile
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python-distribute
+ depends = python
+ source = https://github.com/giampaolo/pysendfile/archive/release-2.0.1.tar.gz
+ md5sums = 928b468e0676c3f90a824b472fbaf4b3
+
+pkgname = python-sendfile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3ee1d6ae04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9d86739a5de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer : Darshit Shah <darnir@gmail.com>
+# Contributor : Gustavo Alvarez <sl1pkn07@gmail.com>
+#
+pkgname=python-sendfile
+_pkgname=pysendfile
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="A Python interface to sendfile(2)"
+url="https://github.com/giampaolo/pysendfile"
+license=('MIT')
+arch=('i686' 'x86_64')
+depends=('python')
+makedepends=('python-distribute')
+source=("https://github.com/giampaolo/pysendfile/archive/release-${pkgver}.tar.gz")
+md5sums=('928b468e0676c3f90a824b472fbaf4b3')
+
+package() {
+ cd "${srcdir}/${_pkgname}-release-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}