summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD19
2 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5da8e6366272..e83739c68742 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sentry_sdk
pkgdesc = The new Python SDK for Sentry.io
- pkgver = 0.15.1
+ pkgver = 0.16.0
pkgrel = 1
url = https://sentry.io/for/python
arch = any
@@ -8,21 +8,20 @@ pkgbase = python-sentry_sdk
makedepends = python-setuptools
depends = python-urllib3
depends = python-certifi
- optdepends = python-flask
- optdepends = python-blinker
- optdepends = python-bottle
- optdepends = python-falcon
- optdepends = python-django
- optdepends = python-sanic
- optdepends = python-celery
- optdepends = python-beam
- optdepends = python-rq
- optdepends = python-aiohttp
- optdepends = python-tornado
- optdepends = python-sqlalchemy
- optdepends = python-pyspark
- source = https://pypi.org/packages/source/s/sentry-sdk/sentry-sdk-0.15.1.tar.gz
- sha256sums = 3ac0c430761b3cb7682ce612151d829f8644bb3830d4e530c75b02ceb745ff49
+ optdepends = python-flask: adds support for the Flask Web Framework
+ optdepends = python-bottle: adds support for the Bottle Web Framework
+ optdepends = python-falcon: adds support for the Falcon Web Framework
+ optdepends = python-django: adds support for the Django Web Framework
+ optdepends = python-sanic: adds support for the Sanic Web Framework
+ optdepends = python-celery: adds support for the Celery Task Queue System
+ optdepends = python-apache-beam: experimental BeamIntegration
+ optdepends = python-rq: adds support for the RQ Job Queue System
+ optdepends = python-aiohttp: adds support for the AIOHTTP-Server Web Framework
+ optdepends = python-tornado: adds support for the Tornado Web Framework
+ optdepends = python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs
+ optdepends = python-pyspark: adds support for the Python API for Apache Spark
+ source = https://pypi.org/packages/source/s/sentry-sdk/sentry-sdk-0.16.0.tar.gz
+ sha256sums = da06bc3641e81ec2c942f87a0676cd9180044fa3d1697524a0005345997542e2
pkgname = python-sentry_sdk
diff --git a/PKGBUILD b/PKGBUILD
index 4109641c345e..b86866780989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
_name=sentry-sdk
-pkgver=0.15.1
+pkgver=0.16.0
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
arch=('any')
@@ -9,11 +9,20 @@ url="https://sentry.io/for/python"
license=('BSD')
depends=('python-urllib3' 'python-certifi')
makedepends=('python-setuptools')
-optdepends=('python-flask' 'python-blinker' 'python-bottle' 'python-falcon' 'python-django'
- 'python-sanic' 'python-celery' 'python-beam' 'python-rq' 'python-aiohttp'
- 'python-tornado' 'python-sqlalchemy' 'python-pyspark')
+optdepends=('python-flask: adds support for the Flask Web Framework'
+ 'python-bottle: adds support for the Bottle Web Framework'
+ 'python-falcon: adds support for the Falcon Web Framework'
+ 'python-django: adds support for the Django Web Framework'
+ 'python-sanic: adds support for the Sanic Web Framework'
+ 'python-celery: adds support for the Celery Task Queue System'
+ 'python-apache-beam: experimental BeamIntegration'
+ 'python-rq: adds support for the RQ Job Queue System'
+ 'python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
+ 'python-tornado: adds support for the Tornado Web Framework'
+ 'python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs'
+ 'python-pyspark: adds support for the Python API for Apache Spark')
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('3ac0c430761b3cb7682ce612151d829f8644bb3830d4e530c75b02ceb745ff49')
+sha256sums=('da06bc3641e81ec2c942f87a0676cd9180044fa3d1697524a0005345997542e2')
build() {
cd "$_name-$pkgver"