summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8302c6450884..76a56f2aa494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sentry_sdk
pkgdesc = The new Python SDK for Sentry.io
- pkgver = 0.16.1
+ pkgver = 0.16.2
pkgrel = 1
url = https://sentry.io/for/python
arch = any
@@ -20,8 +20,10 @@ pkgbase = python-sentry_sdk
optdepends = python-tornado: adds support for the Tornado Web Framework
optdepends = python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs
optdepends = python-pyspark: adds support for the Python API for Apache Spark
- source = https://pypi.org/packages/source/s/sentry-sdk/sentry-sdk-0.16.1.tar.gz
- sha256sums = 380a280cfc7c4ade5912294e6d9aa71ce776b5fca60a3782e9331b0bcd2866bf
+ optdepends = python-pure_eval: for richer stacktraces & additional variables
+ optdepends = python-executing: for richer stacktraces & better function names
+ source = https://pypi.org/packages/source/s/sentry-sdk/sentry-sdk-0.16.2.tar.gz
+ sha256sums = 38bb09d0277117f76507c8728d9a5156f09a47ac5175bb8072513859d19a593b
pkgname = python-sentry_sdk
diff --git a/PKGBUILD b/PKGBUILD
index 3c63851148a2..62946ef41907 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-sentry_sdk
_name=sentry-sdk
-pkgver=0.16.1
+pkgver=0.16.2
pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
arch=('any')
@@ -20,9 +20,11 @@ optdepends=('python-flask: adds support for the Flask Web Framework'
'python-aiohttp: adds support for the AIOHTTP-Server Web Framework'
'python-tornado: adds support for the Tornado Web Framework'
'python-sqlalchemy: captures queries from SQLAlchemy as breadcrumbs'
- 'python-pyspark: adds support for the Python API for Apache Spark')
+ 'python-pyspark: adds support for the Python API for Apache Spark'
+ 'python-pure_eval: for richer stacktraces & additional variables'
+ 'python-executing: for richer stacktraces & better function names')
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('380a280cfc7c4ade5912294e6d9aa71ce776b5fca60a3782e9331b0bcd2866bf')
+sha256sums=('38bb09d0277117f76507c8728d9a5156f09a47ac5175bb8072513859d19a593b')
build() {
cd "$_name-$pkgver"