summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eac468f23cd..b094a0c5712b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = python-sgp4
pkgdesc = Track earth satellite TLE orbits using up-to-date 2010 version of SGP4
pkgver = 2.23
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.org/project/sgp4/
arch = x86_64
license = MIT
- makedepends = python-setuptools
+ checkdepends = python-installer
+ makedepends = python-build
+ makedepends = python-installer
+ depends = gcc-libs
+ depends = glibc
+ depends = python
depends = python-numpy
source = https://files.pythonhosted.org/packages/source/s/sgp4/sgp4-2.23.tar.gz
sha256sums = d8addc53a2fb9f88dee6bfd401d2865b014cc0b57bf2cee69bdee8d9685d5429
diff --git a/PKGBUILD b/PKGBUILD
index 3444afc080c4..86ae5716ba47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
pkgname='python-sgp4'
_name="${pkgname#python-}"
pkgver='2.23'
-pkgrel=1
+pkgrel=2
pkgdesc="Track earth satellite TLE orbits using up-to-date 2010 version of SGP4"
url="https://pypi.org/project/sgp4/"
-depends=('python-numpy')
-makedepends=('python-setuptools')
+depends=('gcc-libs' 'glibc' 'python' 'python-numpy')
+makedepends=('python-build' 'python-installer')
+checkdepends=('python-installer')
license=('MIT')
arch=('x86_64')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
@@ -18,6 +19,11 @@ build() {
python -m build --wheel --no-isolation
}
+#check() {
+# cd "${srcdir}/${_name}-${pkgver}"
+# python sgp4/tests.py
+#}
+
package() {
cd "${srcdir}/${_name}-${pkgver}"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname"