summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d560c64ab12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sha3
+ pkgdesc = A Python module that implements SHA-3 (Keccak) with a hashlib-like interface
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/bjornedstrom/python-sha3
+ arch = i686
+ arch = x86_64
+ license = PSF
+ depends = python
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/s/sha3/sha3-0.2.1.tar.gz
+ md5sums = 95af0d74b1c4593062599a4b2e0ad951
+
+pkgname = python-sha3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c71f9dafe132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: robertfoster
+
+_name=sha3
+pkgname=python-${_name}
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A Python module that implements SHA-3 (Keccak) with a hashlib-like interface"
+arch=('i686' 'x86_64')
+url="https://github.com/bjornedstrom/python-sha3"
+license=('PSF')
+depends=('python')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/s/sha3/sha3-$pkgver.tar.gz")
+
+build() {
+ cd $srcdir/${_name}-$pkgver
+ python setup.py build
+}
+package() {
+ cd $srcdir/${_name}-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+md5sums=('95af0d74b1c4593062599a4b2e0ad951')