summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a431a136110d..dab6db50bc01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,14 +5,13 @@ pkgbase = python-shortuuid-git
url = https://github.com/skorokithakis/shortuuid
arch = any
license = BSD
- makedepends = git
- makedepends = python-setuptools
+ makedepends = python-build
makedepends = python-installer
- makedepends = python-poetry
+ makedepends = python-wheel
+ makedepends = python-poetry-core
depends = python
provides = python-shortuuid
conflicts = python-shortuuid
- replaces = python-shortuuid
options = !emptydirs
source = git+https://github.com/skorokithakis/shortuuid.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 971267e9d04a..80842e5150dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,11 @@ arch=(any)
url="https://github.com/skorokithakis/shortuuid"
license=('BSD')
depends=('python')
-makedepends=('git' 'python-setuptools' 'python-installer' 'python-poetry')
+makedepends=(python-{build,installer,wheel}
+ python-poetry-core)
options=(!emptydirs)
provides=('python-shortuuid')
-replaces=('python-shortuuid')
conflicts=('python-shortuuid')
-#optdepends=('')
source=('git+https://github.com/skorokithakis/shortuuid.git')
_gitname="shortuuid"
@@ -30,7 +29,13 @@ build() {
poetry build
}
+check() {
+ cd "$srcdir/$_gitname"
+ python -m unittest discover
+}
+
package() {
- cd "$srcdir/$_gitname"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$srcdir/$_gitname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
}