summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28354790315b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-sibc-git
+ pkgdesc = Supersingular Isogeny Based Cryptographic constructions
+ pkgver = 1.0.1
+ pkgrel = 2
+ url = https://github.com/JJChiDguez/sibc
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-matplotlib
+ depends = python-networkx
+ depends = python-numpy
+ depends = python-progress
+ provides = python-sibc
+ source = python-sibc::git+https://github.com/JJChiDguez/sibc.git
+ sha256sums = SKIP
+
+pkgname = python-sibc-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16c717b1cae8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: calesanz <contrib at calesanz dot me>
+
+_pkgname='python-sibc'
+pkgname="${_pkgname}-git"
+pkgver=1.0.1
+pkgrel=2
+pkgdesc='Supersingular Isogeny Based Cryptographic constructions'
+arch=('any')
+url='https://github.com/JJChiDguez/sibc'
+license=('GPL3')
+depends=('python'
+ 'python-click'
+ 'python-matplotlib'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-progress'
+ )
+makedepends=('git' 'python-setuptools')
+optdepends=()
+provides=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+}
+
+# vim: ts=2 sw=2 et: